[GRASSLIST:4939] gmake5 woes

H. Bowman ihatejunkyabastards at yahoo.com
Tue Nov 12 11:54:03 EST 2002

Today I recompiled the GRASS sources with the new Tcl/Tk 8.4 and libpng2, 
but had to revert to Tcl/Tk 8.3 due a to NVIZ compile error, and now 
gmake5 doesn't make good post-compile modules. 
wish and related symlinks seem to be pointing back to tcl8.3 versions, and 
this was done before I compiled the main package.

Not trusting 'make distclean', I uninstalled and started afresh from the 
.tar.gz package, which goes fine, and I can reinstall and run grass 
without problems. If I throw my modified module in the source tree before 
starting, it makes it in and everything works fine.

However, if I later compile a modified module with gmake5, and then copy 
the new binary to /usr/local/grass5/bin/ (with grass running), strange 
things start happening.

Specifically, within grass, ANY binary grass module I run will execute my 
new module, but if I pass the 'help' option, the 'Usage:' line lists the 
name of the module I tried to run with the rest of the help screen from my 
module. The only thing that works properly is the new module (which is 
your only option anyway..).

If I copy back the old binary version of the module from the full compile, 
everything magically goes back to normal. All this happens even if I never 
invoke my module during the grass session, which strikes me as odd.

This method of using gmake5 worked fine before the recompile, and it all 
works fine if I recompile the whole thing with my new module. gmake5 just 
seems to be linking against the wrong library somehow? could there be a 
.rc file somewhere that has a bad entry?? Corrupted memory?

The only other thing I changed (that I can think of) was adding 
-march=pentiumpro to the compile flags.

any ideas?

I'm running Debian/Sarge GNU/Linux 2.4.19, i686, and GRASS 5.0.0.

More information about the grass-user mailing list