[GRASSLIST:1908] RE: configuring Grass5.03 on Debian - includes locations

Jim Browne jbrowne at liu.edu
Fri Nov 28 14:04:18 EST 2003

Thanks Glynn and Holger for the input.

My problem with zlib was that the development package was not installed 
correctly. It was originally installed from a tar ball so the parts were 
mostly there, but not all. Overwriting with
   apt-get zlib1g-dev
solved that problem.

   After Googling for the Debian version of package names of other needed 
headers and libs I now have the compile going.The Debian people must have 
already solved the links problem that Holger had.

  TWO QUIRKS OF NOTE for maintainers

  Debian put some headers in sub-directories.

  TCL headers ended up in /usr/include/tcl8.0
  postgresql headers are in /usr/include/postgresql

  I simply copied the contents into /usr/include to get the compile going.

  Please include these as alternate linux locations in future versions of 
configure for fellow Debian users. Thanks.

  For those compiling on Debian Woody in the future, here is a partial list of 
the debian "apt-get" names for the packages based on what I still needed:

   mesag3-dev  OR xlibmesa3-dev
   fftw-dev  ( & sfftw-dev ?)

  Thanks again for the feedback.


>===== Original Message From Holger Zebner <holgerzebner at gmx.de> =====
>> There should be a file (or symlink to one) called either libz.a or
>> libz.so. The usual situation on Linux is that libz.so is a symlink to
>> the actual file, and the actual file includes the version number,
>> e.g.:
>> $ ls -l /usr/lib/libz.so
>> lrwxrwxrwx    1 root     root           13 Apr  2  2002 /usr/lib/libz.so ->
>> libz.so.1.1.3
>> There will normally be another symlink which only contains the major
>> version number, e.g.:
>> $ ls -l /usr/lib/libz.so.?
>> lrwxrwxrwx    1 root     root           13 Apr  2  2002 /usr/lib/libz.so.1
>> -> libz.so.1.1.3
>> The unversioned link (libz.so) is needed for compilation. FWIW, RedHat
>> puts these links in the *-devel (development) packages (e.g.
>> zlib-devel), along with the headers. The versioned link (libz.so.1) is
>> needed at run-time. The actual file (e.g. libz.so.1.1.3) is needed for
>> both.
>> I don't know how Debian organises packages. If, like RedHat, it has
>> separate development packages, you will need these in order to compile
>I don't know either how they organize the packages, yet. Sometimes in a
>non-conventional manner regarding the problems when installing from source.
>I did kinda workaround:
>I made a directory called links-for-install
>Then I made all symlinks needed by GRASS in that dir. Like if you need
>libtiff.a and this isn't found by configure link it there and specify it in
>the ./configure --with-libtiff=/thedir
>my link dir:
>ls /usr/links-for-install/
>insgesamt 8,0K
>drwxr-xr-x    2 root     root         4,0K 2003-11-25 00:16 .
>drwxr-xr-x   15 root     root         4,0K 2003-11-25 00:13 ..
>lrwxrwxrwx    1 root     root           18 2003-11-25 00:15 libproj.a -> 
>lrwxrwxrwx    1 root     root           19 2003-11-25 00:15 libproj.la -> /
>lrwxrwxrwx    1 root     root           21 2003-11-25 00:15 libproj.so.0 -> /
>lrwxrwxrwx    1 root     root           25 2003-11-25 00:15 libproj.so.0.4.1
>-> /usr/lib/libproj.so.0.4.1
>lrwxrwxrwx    1 root     root           18 2003-11-25 00:11 libtiff.a -> 
>lrwxrwxrwx    1 root     root           19 2003-11-25 00:11 libtiff.so -> /
>lrwxrwxrwx    1 root     root           21 2003-11-25 00:11 libtiff.so.3 -> /
>lrwxrwxrwx    1 root     root           25 2003-11-25 00:12 libtiff.so.3.5.7
>-> /usr/lib/libtiff.so.3.5.7
>lrwxrwxrwx    1 root     root           23 2003-11-25 00:16 projects.h -> /
>lrwxrwxrwx    1 root     root           21 2003-11-25 00:12 tiffio.h -> /usr/
>Donno if this is a good manner of system administartion but I got GRASS
>installed through this.

More information about the grass-user mailing list