[GRASSLIST:3123] Re: Problem with monitor....

Massimiliano Cannata massimiliano.cannata at supsi.ch
Fri Apr 9 05:50:04 EDT 2004

Ok thanks for the help, now i've compiled all the grass code on my 
external drive and got no error.
Now i can run grass with:
#> /mnt/maxtor_linux/grass_home/grass53/bin/grass53
but still remain some problem.....

- Monitor problem:
I can run a monitor only if i am ROOT, otherwise i get the same old 
error: ERROR: In main.c: Couldn't get socket path.

whoami gives the rigth answer;
/tmp/grass-<username> is a directory, exist and i'm the owner;

what am i missing? maybe mounting my external drive (where i put my bin)?
i use in fstab:  /dev/sda5     /mnt/maxtor_linux    ext2    defaults    1 2

- Library problem:
I cannot see libproj.so.0 because my LD_LIBRARY_PATH doesn't contain the 
path /usr/local/lib.
if i run:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
everything goes fine.....

but it should be already contemplate in some grass variable, in fact i run:

CFLAGS="-O3 -march=pentium4 -Wall" LDFLAGS="-s" ./configure  
--with-postgres-includes=/usr/include/pgsql/server/ --with-motif 
--with-motif-libs=/usr/X11R6/LessTif/Motif1.2/lib/ --with-blas 
--with-lapack --with-glw --with-dbm 
--with-dbm-includes=/usr/include/gdbm --with-freetype 
--with-freetype-includes=/usr/include/freetype2/ --without-readline 
--with-fftw --with-proj --with-proj-libs=/usr/local/lib --with-cxx

Any helps to give me?
Thanks, and sorry for my limited linux knowledge

Glynn Clements wrote:

>>- when i call d.mon start=x0 i get this error message:
>>    GRASS:~ > d.mon start=x0
>>    ERROR: In main.c: Couldn't get socket path.
>Possible reasons for this error are:
>1. It couldn't figure out your username (does the "whoami" program
>give the correct information)?
>2. It couldn't create the /tmp/grass-<username> directory.
>3. The /tmp/grass-<username> directory already exists, but you don't
>own it.
>4. /tmp/grass-<username> already exists, but it isn't a directory.
>>    Failed to get socket name for monitor <x0>.
>>    Problem selecting x0. Will try once more
>>    Failed to get socket name for monitor <x0>.
>These are a direct consequence of the driver failing to start due to
>the above error.
Ing.  Massimiliano Cannata
Istituto di Scienze della Terra - SUPSI
C.P. 72 - CH-6952 Canobbio (Ticino, Switzerland)
Tel +41 91 /935 12 25 - Fax +41 91 /935 12 09
eMail: massimiliano.cannata at supsi.ch
Internet: http://www.ist.supsi.ch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20040409/61decd50/attachment.html

More information about the grass-user mailing list