[GRASSLIST:6625] SRTM-import problem on SUSE 7.3 (solved)

Karl Broich b61bro at b61srv5.bauv.unibw-muenchen.de
Tue Apr 26 06:23:34 EDT 2005

I ran in two problems compiling GRASS 6.0 from source on SUSE 7.3

1. gdal 1.2.6 did not compile. The compiler moans about -fmessage-length=0 
2. white monitor box

Solution to item 1 by Frank Warmerdam :
Ah, I think I get it.  The geos-config command is used to fetch compiler
options and it would appear that is where the -fmessage-length=0 thing
is coming from.  If you look in GDALmake.opt and search for GEOS_INC
just remove any peculiar platform specific options from it.
I deleted just the -fmessage-length=0 option and compiled gdal 1.2.6 

Solution to item 2 :
Probably some files were corrupted. Following a hint from the GRASS-list I 
deleted the whole location and made a new setup. After this the monitor 
displayed the imported SRTM-raster properly.

-> it is possible to run an up-to-date GRASS 6.0 on an old SUSE 7.3 system :)

Thanks to Frank Warmerdam and the GRASS-list


Dr.-Ing. Karl BROICH			Tel:	+49 / (0) 89 / 6004 2478
Universität der Bundeswehr München	Fax:	+49 / (0) 89 / 6004 3858
Institut für Wasserwesen
Werner-Heisenberg-Weg 39
D 85577 Neubiberg

More information about the grass-user mailing list