[GRASS-user] RE: Problem querying layers other than '1' in gi s.m

Patton, Eric epatton at nrcan.gc.ca
Wed Sep 20 09:44:51 EDT 2006

>You do not have to duplicate the points, but IIUC you have to assign a
>category value for each point in each layer. (See

I'm probably misunderstanding the use of layers in general, but I thought it
was analogous to 'joined tables' in Arc (one geometry, many tables).

Thinking about how I linked the tables to the vector, I just realized how I
may have made a mistake. The vector in question is a series of points
representing sample locations. Layer one contains a table with cat,
Timestamp, Easting and Northing. I wanted to create a second layer linking
to a table containing biological analyses of the sample data. The only
column in common between layer one and layer two is the timestamp field. Do
I also need a field in layer 2 telling what cat in layer 1 it belongs to?
Maybe that is why I can't query anything from layer 2. If I am right here,
how can I construct an SQL statement to populate layer 2 with the
corresponding cat from layer 1 where the timestamps in each table match?

>BTW: have you tried to query on the command line (using d.mon x0 to open
>a monitor) ?


Yes, I tried the same thing using d.what.vect -e and only layer one's
attributes are queried.

~ Eric.

More information about the grass-user mailing list