[GRASS-user] Re: Cygwin winGRASS 6.2 Errors!

Hamish hamish_nospam at yahoo.com
Wed Feb 14 21:09:26 EST 2007

yuri bay wrote:
> I have encountered the following error when I first time invoked
> the Cygwin  winGRASS 6.2 after I have successfully installed it. 
> I am using both native  binary and the new cygwin 6.2 winGRASS.  I
> have copy and past my GRASSDATA  dir into cygwin directory so that
> I can access the same data using cygwin  winGRASS.  But when I
> have selected the correct directory and mapset, the  following
> error occured on the xwindow:
> GRASS 6.2.1 (L_UK):~ > child process exited abnormally, by using
> gis.m on the xwin will give the same error.

I have just tried installing the 6.2.1 Cygwin package in Windows XP,
I get the same error.  (I also just updated the install instructions)

A number of important modules are not built properly. (e.g. g.region)

xganim did build ok, so you can try that out if you want Casey.

Before I get into that, any objections to adding the following extra
dependencies to setup.ini?
  (used in various scripts/; need Markus's help as it isn't in CVS)
util-linux   # for more.exe; used as the pager for g.list.

gritty details of the broken Cygwin package:

at the Cywgin prompt:
$ startx
in the new xterm:
$ grass62 

# ... TclTk startup screen, select data dir and mapset, [Enter GRASS] ...

Starting GRASS ...
//usr/local/share/grassdata/spearfish60/user1/.gislock: No such host or network path
ERROR: /usr/local/grass-6.2.1/etc/lock:
Admin is currently running GRASS in selected mapset. Concurrent use not allowed.

I guess it doesn't like /usr/local/share/grassdata/. Pity, as this is a
multi-user machine in the student lab.

$ cp -r /usr/local/share/grassdata/ ~

$ grass62
# GUI Startup
# select spearfish
# gis.m starts up but then crashes:
GRASS 6.2.1 (spearfish60):~ > child process exited abnormally

GRASS 6.2.1 (spearfish60):~ > g.proj -p
GRASS 6.2.1 (spearfish60):~ > g.region -p    
GRASS 6.2.1 (spearfish60):~ > g.region --help
GRASS 6.2.1 (spearfish60):~ > echo $?
GRASS 6.2.1 (spearfish60):~ > g.proj --help
GRASS 6.2.1 (spearfish60):~ > echo $?
GRASS 6.2.1 (spearfish60):~ > r.info --help
 Outputs basic information about a user-specified raster map layer.
[... ok]

GRASS 6.2.1 (spearfish60):/usr/local/grass-6.2.1/bin > ls -l g.proj g.region
-rwxr-x---+ 1 Admin Users  67440 Feb 10 04:42 g.proj
-rwxr-x---+ 1 Admin Users 117064 Feb 10 04:42 g.region

GRASS 6.2.1 (spearfish60):~ > g.parser 
Usage: g.parser [-t] <filename> [<argument> ...]
GRASS 6.2.1 (spearfish60):~ > r.terraflow
[opens tcltk gui menu]
GRASS 6.2.1 (spearfish60):~ > xganim view1=elevation.dem,slope
[works ok]
GRASS 6.2.1 (spearfish60):~ > nviz elevation.dem
GRASS 6.2.1 (spearfish60):~ > 

cd /usr/local/grass-6.2.1/bin
for CMD in g.* ; do
  ANS=`$CMD --help 2>&1`
  if [ -n "$ANS" ] ; then
    echo "$CMD ok"
    echo "$CMD NOT ok"

g.access ok
g.ask ok
g.copy NOT ok
g.filename ok
g.findfile ok
g.gisenv ok
g.list ok
g.mapset ok
g.mapsets ok
g.parser ok
g.pnmcomp ok
g.proj NOT ok
g.region NOT ok
g.remove NOT ok
g.rename NOT ok
g.setproj NOT ok
g.tempfile ok
g.transform NOT ok
g.version ok

r.carve NOT ok
r.contour NOT ok
r.cost NOT ok
r.drain NOT ok
r.flow NOT ok
r.in.gdal NOT ok
r.le.setup NOT ok
r.param.scale NOT ok
r.proj NOT ok
r.random NOT ok
r.region NOT ok
r.resamp.rst NOT ok
r.sim.sediment NOT ok
r.sim.water NOT ok
r.sun NOT ok
r.sunmask NOT ok
r.surf.fractal NOT ok
r.surf.gauss NOT ok
r.surf.random NOT ok
r.to.vect NOT ok
r.volume NOT ok
r.walk NOT ok

all v.* NOT ok

ps.map NOT ok

d.ask ok
d.barscale ok
d.colorlist ok
d.colors ok
d.colortable ok
d.erase ok
d.extend NOT ok
d.extract NOT ok
d.font ok
d.font.freetype ok
d.frame ok
d.geodesic ok
d.graph ok
d.grid NOT ok
d.his ok
d.histogram ok
d.info ok
d.labels ok
d.legend ok
d.linegraph ok
d.mapgraph ok
d.measure ok
d.menu ok
d.mon ok
d.nviz ok
d.paint.labels ok
d.path NOT ok
d.profile ok
d.rast ok
d.rast.arrow ok
d.rast.edit ok
d.rast.num ok
d.rgb ok
d.rhumbline ok
d.save ok
d.text ok
d.text.freetype ok
d.title ok
d.vect NOT ok
d.vect.chart NOT ok
d.what.rast ok
d.what.vect NOT ok
d.where NOT ok
d.zoom NOT ok

db.* ok

i.cca NOT ok
i.class NOT ok
i.cluster NOT ok
i.fft NOT ok
i.gensig NOT ok
i.gensigset NOT ok
i.group NOT ok
** i.his.rgb ok
i.ifft NOT ok
i.maxlik NOT ok
i.ortho.photo NOT ok
i.pca NOT ok
i.points NOT ok
i.rectify NOT ok
** i.rgb.his ok
i.smap NOT ok
i.target NOT ok
i.vpoints NOT ok
i.zc NOT ok

r3.* ok

xganim ok


More information about the grass-user mailing list