[GRASS-user] GRASS 6.2.1-1 Installation Question

Ramu Narayanan ramu.nm at gmail.com
Mon Feb 19 18:40:07 EST 2007


'd.mon start=x1' and 'd.mon select=x1' both yeild the same result as 'd.monx0'

The monitor window is indeed opening up but I can't properly select or use
it.  If I attempt to do so using the select command, I am told that the
'socket is already in use or not accepting connections.'  The xDriver.exe is
shown as a process in the Window process list.  Restarting cygwin does not
solve the problem.

Another point to note:  When I type exit in the terminal window, I am told
that the monitors are being closed.  This however does not happen as I need
to kill the monitor process (using ps) to actually close the monitor.  The
monitor windows therefore appears to hang.  I am currently opening the grass
in gui mode.  I also note, however, that exiting in the terminal does not
close the output, map display or GRASS manager windows.  I get the same
result (monitors hanging) if I run d.mon from the gui or from the terminal.


On 2/19/07, Hamish <hamish_nospam at yahoo.com> wrote:
> Ramu Narayanan wrote:
> > d.mon x0
> >
> > The following message appears:
> >
> > GRASS 6.2.1 (spearfish60):~ > d.mon x0
> > using default visual which is TrueColor
> > ncolors: 16777216
> > Graphics driver [x0] started
> > Socket is already in use or not accepting connections.
> > Use d.mon to select a monitor
> > Problem selecting x0. Will try once more
> > Socket is already in use or not accepting connections.
> > Use d.mon to select a monitor
> > GRASS 6.2.1 (spearfish60):~ > d.rast soils
> > No graphics monitor has been selected for output.
> > Please run "d.mon" to select a graphics monitor.
> >
> > I get similar messages regardless of whether I do this in the GRASS
> > command prompt or the Grass Manager window.
> > The list and info commands appear to be working.
> does the same happen after quiting Cygwin and restarting?
> what about,
> d.mon start=x1
> d.mon select=x1
> (up to x6, "d.mon x0" is a shortcut to the above two commands)
> Hamish
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20070219/a31fb0f3/attachment.html

More information about the grass-user mailing list