[GRASS-user] GRASS 6.2.1-1 Installation Question

Ramu Narayanan ramu.nm at gmail.com
Mon Feb 19 22:41:54 EST 2007

Typing in d.mon -L indicates that the x0 monitor is not running after I type
d.mon x0

This is verified by trying d.mon stop=x0 which indicated that x0 was not

The only indication i see that it was running apart from the open window was
by trying d.mon select=x0 which indicates that 'socket is already in use or
is not accepting connections'.  I cannot close the monitor by hitting the
close button.

I tried this before and after removing my firewall that I have installed but
without any changes in the resulting messages.

I found this link online which appears to indicate that there may be a
problem with xDriver when working with Gentoo but I'm not sure if it applies
to my situation:

Is there something else that I might be able to try?


On 2/19/07, Glynn Clements <glynn at gclements.plus.com> wrote:
> Ramu Narayanan wrote:
> > 'd.mon start=x1' and 'd.mon select=x1' both yeild the same result as '
> d.monx0'
> >
> > The monitor window is indeed opening up but I can't properly select or
> use
> > it.  If I attempt to do so using the select command, I am told that the
> > 'socket is already in use or not accepting connections.'  The
> xDriver.exe is
> > shown as a process in the Window process list.  Restarting cygwin does
> not
> > solve the problem.
> IOW, the driver seems to be working, but simply not accepting
> connections.
> Do you have any firewall software which might get in the way? Cygwin
> emulates Unix-domain sockets using TCP/IP sockets, so if there's
> anything blocking "inbound" network connections, that will cause
> problems.
> [I have ZoneAlarm on my Windows machine, and every d.* program brings
> up a dialog asking me if I want to allow the connection. Starting
> XDRIVER or the PNG driver brings up a dialog asking if I want to allow
> it to operate as a server.]
> > Another point to note:  When I type exit in the terminal window, I am
> told
> > that the monitors are being closed.  This however does not happen
> That's to be expected in light of the above; if mon.stop can't connect
> to the socket, it can't tell the monitor to terminate.
> > as I need
> > to kill the monitor process (using ps) to actually close the monitor.
> Does clicking the close button on the Window work? If not, that
> suggests that something else may be involved (or not; it's possible
> that XDRIVER is blocking in the middle of trying to accept a
> connection).
> --
> Glynn Clements <glynn at gclements.plus.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20070219/3bafd07d/attachment.html

More information about the grass-user mailing list