[GRASS-user] grass6.4 develbrunch revision 32726: undefined reference to `G_no_gisinit'

Glynn Clements glynn at gclements.plus.com
Thu Aug 14 10:00:26 EDT 2008

Nikos Alexandris wrote:

> Funny! Today I recompiled all osgeo packages on my Ubuntu-box (install
> proj4, install geos, compile gdal_stable without GRASS support, compile
> GRASS6.4.svn, compile gdal-grass-plugin, compile qgis_0_11_0). I
> carefully linked properly to the "local" installed libraries while
> configuring QGIS with ccmake.
> Now, while I run QGIS from within GRASS and use GRASS tools without
> problems, I can't even load the GRASS-plugin if I run QGIS outside of
> the GRASS-shell.
> The error message is:
> qgis: symbol lookup error: /usr/local/lib/libqgisgrass.so.1.0: undefined
> symbol: G__no_gisinit

QGIS is built for the new library but is loading an old version of the
library at run time.

When you start a GRASS session with the grass64 (etc) script, it sets
LD_LIBRARY_PATH to include $GISBASE/lib. Outside of a GRASS session,
it will use the normal LD_LIBRARY_PATH setting and /etc/ld.so.cache.

Glynn Clements <glynn at gclements.plus.com>

More information about the grass-user mailing list