[GRASS-user] g.manual tries to run C:\Program Files\Internet Exporer\iexplore (the 'L' is missing from 'Explorer')

Frank Bilki fbilki at gmail.com
Sat Jul 25 10:58:38 EDT 2009

Hi All,

Being very, very new to GRASS (6.4.0svn, installed via OSGeo4W) I am reading
as much documentation as I can lay my hands on, but I keep hitting a
recurring problem:

Every time I run g.manual I get an error saying it cannot find 'C:\Program
Files\Internet Exporer\iexplore'. After reading the message very carefully I
realised it is because the 'L' is missing from 'Explorer'.

According to the manual page on GRASS Variables and Environment Variables,
GRASS_HTML_VIEWER is a 'shell environment' variable (this name makes no
sense to me running under Windows Vista) and I should be able to set it to
the full path of my current HTML browser. I tried creating a new System
Variable from My Computer called GRASS_HTML_VIEWER containing the
appropriate path. It didn't work; GRASS still looked for Internet 'Exporer'.

After a great deal of searching my computer I discovered that the offending
path is stored within the 'C:\OSGeo4W\etc\ini\grass.bat' file. However, I
can't find any references in the documentation that could lead me there in a
more controlled way. 

But, even after I added the 'L' to the path I still get the same error:

C:\Program Files\Internet Explorer\iexplore: command not found

What is wrong with this command? Is it because there are spaces in the
folder names? I've tried putting it in quotes, changing %PROGRAMFILES% to
C:\Program Files, and putting the .exe after iexplore, but nothing seems to

I know there are alternative ways to get to the documentation (which are
what I'm using now), but I am using this as a learning exercise and I want
to understand exactly what's happening here. I also wanted to share this
with others who might be having the same problem with this particular



More information about the grass-user mailing list