[GRASS-user] g.manual tries to run C:\Program Files\Internet Exporer\iexplore (the 'L' is missing from 'Explorer')

Frank Bilki fbilki at gmail.com
Sun Jul 26 01:47:56 EDT 2009

Hi Markus,

Thanks for the suggestion and the link to the changeset. It turns out I had
already made that change, having also discovered grass64.bat after editing

That particular command was commented out in my version; I tried
un-commenting it but I still got the same error.

The relevant contents of my two batch files are:

rem Path to your web browser

I also tried changing the above statement to:
set GRASS_HTML_BROWSER=%PROGRAMFILES%\Internet Explorer\iexplore.exe

but I still got the same error.

set GRASS_HTML_BROWSER=%PROGRAMFILES%\Internet Explorer\iexplore

I can confirm that grass.bat is executed, but it also appears to be
overridden by grass64.bat (I can tell because the g.manual error contains
"iexplorer.exe" rather than just "iexplore").

After some investigation I also found another copy of grass64.bat at
C:\OSGeo4W\apps\grass\bin, however the second copy does not appear to be
executed and is missing several statements.

The operation and purpose of all the batch files isn't clear to me at the
moment but I will help where I can to diagnose the problem.




Message: 2
Date: Sat, 25 Jul 2009 18:48:52 +0200
From: Markus Neteler <neteler at osgeo.org>
Subject: Re: [GRASS-user] g.manual tries to run C:\Program Files\Internet
Exporer\iexplore (the 'L' is missing from 'Explorer')
To: Frank Bilki <fbilki at gmail.com>	
Cc: GRASS user list <grass-user at lists.osgeo.org>
	<86782b610907250948m49ba0b0ey92eec0a1394e068 at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1

On Sat, Jul 25, 2009 at 4:58 PM, Frank Bilki<fbilki at gmail.com> wrote:
> Hi All,
> Being very, very new to GRASS (6.4.0svn, installed via OSGeo4W) I am
> as much documentation as I can lay my hands on, but I keep hitting a
> recurring problem:
> Every time I run g.manual I get an error saying it cannot find 'C:\Program
> Files\Internet Exporer\iexplore'. After reading the message very carefully
> realised it is because the 'L' is missing from 'Explorer'.

This has been reported in
and AFAIK been fixed. Unfortunately the OSGeo4W-GRASS is
old(er) and does not seem to incorporate this fix. We made
several other fixes, too, which are missing.

Action item: We need a volunteer to take over compilation of the

> According to the manual page on GRASS Variables and Environment Variables,
> GRASS_HTML_VIEWER is a 'shell environment' variable (this name makes no
> sense to me running under Windows Vista) and I should be able to set it to
> the full path of my current HTML browser. I tried creating a new System
> Variable from My Computer called GRASS_HTML_VIEWER containing the
> appropriate path. It didn't work; GRASS still looked for Internet
> After a great deal of searching my computer I discovered that the
> path is stored within the 'C:\OSGeo4W\etc\ini\grass.bat' file. However, I
> can't find any references in the documentation that could lead me there in
> more controlled way.

> But, even after I added the 'L' to the path I still get the same error:
> C:\Program Files\Internet Explorer\iexplore: command not found

I have seen this:

but I wonder if OSGeo4W has a different grass.bat file?

> What is wrong with this command? Is it because there are spaces in the
> folder names? I've tried putting it in quotes, changing %PROGRAMFILES% to
> C:\Program Files, and putting the .exe after iexplore, but nothing seems
> work.

Please check with above changeset, maybe it gives an idea.

> I know there are alternative ways to get to the documentation (which are
> what I'm using now), but I am using this as a learning exercise and I want
> to understand exactly what's happening here. I also wanted to share this
> with others who might be having the same problem with this particular
> version.

Thanks for trying, we really appreciate feedback (and need more power
users for OSGeo4W).


More information about the grass-user mailing list