[GRASS-user] Can I just get rid of Wish?

Michael Margolis mmargoli at gettysburg.edu
Tue Jun 9 13:58:40 EDT 2009

Many thanks to all who responded. Installing TclTk 8.5 put an end to the
prior problem.

Unfortunately, I then got Nick's problem -- impossible to resize a window,
plus some freezes. So I tried something evidently more severe than I had
realized -- resetting GRASS_GUI to wxPtyhon. I probably did this with the
g.gisenv command, although I'm not sure. Anyway, when I attempt to launch I
now get  

ERROR: Invalid user interface specified - <wxPython>.
Use the --help option to see valid interface names.

[Process completed]

The terminal window displaying that message accepts no further input. I
can't figure out how to use that --help option, or how to change GRASS_GUI
without being able to start GRASS. I reinstalled to no avail.

How do I fix this? And then, how can set it up for wxPython?

Thanks much

On 6/8/09 9:45 PM, "William Kyngesburye" <woklist at kyngchaos.com> wrote:

> When you say X11, I assume you mean no GUI, or maybe the GUI in X11?
> Note, there are 2 different GUIs now, and on OSX, 2 variations of one:
> TclTk X11 - works with an X11 TclTk 8.4+.  This requires you to
> compile and install your own TclTk.  I used to include one in the
> application, but not since we got it working with Aqua
> TclTk Aqua - as the warning implies, this needs TclTk 8.5+.  The
> readme says where to find an installer.  This one is preferred.
> wxPython.  This is included in the application.
> Note 1: the TclTk NVIZ is built to use TclTk Aqua 8.5 and won't run
> with 8.4 of any form.
> Note 2: the application startup tries to locate TclTk in some default
> locations and of forms in the following order:
> TclTk 8.5 Aqua
> TclTk 8.5 X11
> TclTk 8.4 X11
> Anyways, after GRASS starts and Wish fails, type in the Terminal:
> g.gisenv set=GRASS_GUI=text
> Thereafter GRASS won't try to start the TclTk GUI.
> On Jun 8, 2009, at 6:49 PM, Michael Margolis wrote:
>> Hi all
>> I have GRASS-6.4 working fine on a Mac laptop, where it opens X11.
>> I've
>> installed it on a desktop, where it insists on opening Wish, and then
>> malfunctions. There is a" Warning: TclTk Aqua 8.4 unsupported" in the
>> Terminal window as it opens. Then an allegation that my projection
>> field is
>> missing when I run, for example, g.region, and some similar errors.
>> This is with Spearfish, the exact same files working on the laptop.
>> Any ideas? Can I just rid of Wish and get the desktop to use X11?
>> Thanks,
>> Michael
>> _______________________________________________
>> grass-user mailing list
>> grass-user at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/grass-user
> -----
> William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>
> http://www.kyngchaos.com/
> "I ache, therefore I am.  Or in my case - I am, therefore I ache."
> - Marvin

More information about the grass-user mailing list