[GRASS-user] Problem with v.dissolve with the sqlite driver

Benjamin Ducke benjamin.ducke at oxfordarch.co.uk
Tue Jun 16 16:00:17 EDT 2009

I have had the same error message when trying to
store data in an SQLite DB file, using v.out.ogr.
Not even a very basic points map would work.
Only the first record, including geometry
and attributes would stored correctly, after that
every record would fail with:

"SQL logic error or missing database"

Unfortunately, this error is very unspecific. Like
SQLite's way of saying "something went really wrong,
but I have no clue what it was".

The problem seems, however, to be on the GRASS side
of things. I am inclined to believe this, because
ogr2ogr had no problems whatsoever dumping the exact
same dataset into the exact same SQLite file.

I tried finding the problem in the GRASS SQLite driver 
for some time, but no luck.

Sorry about not being able to offer a solution at
this point. It is something that needs looking into.


----- Original Message -----
From: "Martin Mainzer" <martmai at gmx.de>
To: grass-user at lists.osgeo.org
Sent: Tuesday, June 16, 2009 5:45:23 PM GMT +00:00 GMT Britain, Ireland, Portugal
Subject: [GRASS-user] Problem with v.dissolve with the sqlite driver


I just installed the grass 6.4.0 RC4 *.rpm from 
on my OpenSuse 10.3 machine.

And here I got a problem that looks for me like the one reported in 2007 
Within the spearfish dataset (nc_spm_08) I entered the sqlite mapset and 
copied the geology map to the splite mapset with

~> g.copy vect=geology at PERMANENT,geology
~>v.dissolve input=geology at sqlite output=geology_diss layer=1 
DBMI-SQLite driver error:
Cannot step:
SQL logic error or missing database

Did I make a mistake or is it a bug?
grass-user mailing list
grass-user at lists.osgeo.org

Files attached to this email may be in ISO 26300 format (OASIS Open Document Format). If you have difficulty opening them, please visit http://iso26300.info for more information.

More information about the grass-user mailing list