[GRASS-user] qgis + grass-plugin = gdal-problem (update)

Craig Leat craig.leat at gmail.com
Sun Mar 1 06:27:32 EST 2009

Hi Achim

Achim wrote:
>> starting qgis(1.0.1) with grass64 I can open a grass location, but when
>> I open a rastermap, qgis terminates with following error:
>> qgis: symbol lookup error: /usr/lib/gdalplugins/gdal_GRASS.so: undefined
>> symbol: G_no_gisinit
>> When I start qgis with grass63 installed, qgis terminates immediately
>> with the same error.
> sorry: not the same error:
> qgis: symbol lookup error: /usr/lib64/libqgisgrass.so.1.0: undefined
> symbol: G__no_gisinit

I'm no guru when it comes to compiling/building, but what I have
noticed using the development versions of grass and qgis is that if I
update and compile grass and forget to re-compile qgis then the grass
plugin disappears from the qgis menu. This is new behaviour that has
appeared in the last couple months. As I remember the older versions
of qgis would throw the error you report when qgis was built for a
different version of grass compared to that currently being accessed.

If you are installing binaries from others read the package notes to
find the revision of grass required and make sure all other versions
and their libraries are removed from your system, including the 32 bit
libraries as you seem to need the 64 bit versions.


More information about the grass-user mailing list