[GRASS-user] gdal, v.in.ogr, Ubuntu intrepid

Casey Vandenberg casey.vandenberg at sjgeophysics.com
Thu Mar 12 17:57:21 EDT 2009

I also ran into the buffer overflow error that many others have been
reporting with a 64 bit 8.10 install of Ubuntu. Instead of installing all of
the debian packages that Paolo did in his fix, I only installed one
(libgdal1-1.5.0_1.5.4-2_amd64.deb).  I kept my old libgdal1-1.5.0 package
that was previously installed, and recompiled Grass. It worked for me and
only required one package installation.

As an aside, I initially tried installing libgdal1-1.6.0 from source and
then recompiled grass. Importing a shapefile using v.in.ogr still returned a
buffer overflow error, but it wasn't getting an error in the same location
as it had prior to the install. I don't have the know how to try and track
down another set of issues, so I gave up on installing from source.  


Paolo Craveri wrote:
> Perhaps solved (I hope)!
> I created a local repository (eg. /usr/local/mydebs); then I download
> from Debian-Lenny all gdal packages
> (libgdal1-1.5.0-grass_1.5.2-1_i386, gdal-bin_1.5.2-3_i386, etc.etc.).
> I updated the repository and my sources.list as explain here:
> http://wiki.clug.org.za/wiki/How_do_I_install_a_.deb_file_I_downloaded_without_compromising_dependencies%3F
> With synaptic I installed all gdal packages and finally I recompiled
> grass6.4 svn without any errors.
> v.in.ogr  works well.
> This is not a elegant solution of course and probably there are better
> ways,  but works.
> -- 
> -- 
> Paolo C.
> Lat. 44° 39' 11.08'' N  Long. 7° 23' 25.26'' E
> _______________________________________________
> grass-user mailing list
> grass-user at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/grass-user

View this message in context: http://n2.nabble.com/gdal%2C-v.in.ogr%2C-Ubuntu-intrepid-tp1886320p2470383.html
Sent from the Grass - Users mailing list archive at Nabble.com.

More information about the grass-user mailing list