[GRASS-user] g.region causing GUI crash...

Jonathan Greenberg greenberg at ucdavis.edu
Wed Mar 25 20:19:17 EDT 2009

Excellent!  So, yes, it turns out I hit my quota on the disk server -- 
our sysadmin raised it, but the same error was occurring.  g.region -d 
worked spectacularly!  Thanks!


Moritz Lennert wrote:
> On 25/03/09 06:51, Markus Neteler wrote:
>> On Wed, Mar 25, 2009 at 4:42 AM, Jonathan Greenberg
>> <greenberg at ucdavis.edu> wrote:
>>> GRASS was working fine and dandy, and after some weird crash with a 
>>> display
>>> window (I forgot to jot down the error), I can no longer launch the 
>>> GUI for
>>> a certain mapset under GRASS 6.4.svn on Debian.  Here's the error I 
>>> get:
>>> After choosing the mapset, the splash comes up, then the Output 
>>> window, then
>>> an error window stating:
>>> "Error setting region (Problem with g.region?): child process exited
>>> abnormally" with an OK button.  Clicking OK kills the Output window, 
>>> and I
>>> get these errors in my terminal window:
>>> GRASS 6.4.svn (pod_sav):/pathto/bioclimate > Error in startup 
>>> script: can't
>>> read "parts(w)": no such variable
>> ...
>> This indicates that g.region fails (as you have seen below).
>>> When I tried to manually set the region:
>>> GRASS 6.4.svn (pod_sav):/pathto/bioclimate > g.region
>>> rast=all_cdec_costd_mincost_1
>>> ERROR: region for current mapset is invalid
>>>      <projection field missing>
>>>      run "g.region"
>> It comes from G__read_Cell_head_array() which is a function
>> to read the raster map header.
>> I suspect that the "all_cdec_costd_mincost_1" raster map [header]
>> is corrupted. 
> It could also be the region file. Try with g.region -d, and if this 
> doesn't work, erase the WIND file in your mapset directory.
> Moritz

More information about the grass-user mailing list