[GRASS-user] Compile and install 6.4.2RC2

Aldo Clerici aldo.clerici at unipr.it
Wed Dec 28 06:46:17 EST 2011

Dear Developers and users,

I'm having troubles in compiling and installing grass6.4.2RC2 on Fedora 10.

I installed Python-2.7.2, wxPython-, numy-1.6.1.

I run:  ./configure --with-cxx --with-python=/usr/local/bin/python2.7-config


with the following output:

GRASS is now configured for:  i686-pc-linux-gnu


  Source directory:            /home/clerici/GRASSprograms/grass-6.4.2RC2

  Build directory:             /home/clerici/GRASSprograms/grass-6.4.2RC2

  Installation directory:      ${prefix}/grass-6.4.2RC2

  Startup script in directory: ${exec_prefix}/bin

  C compiler:                  gcc -g -O2 

  C++ compiler:                c++ -g -O2

  Building shared libraries:   yes

  64bit support:               no

  OpenGL platform:             X11


  MacOSX application:         no

  MacOSX architectures:       

  MacOSX SDK:                 


  Tcl/Tk NVIZ:                yes


  BLAS support:               no

  C++ support:                yes

  Cairo support:              no

  DWG support:                no

  FFMPEG support:             no

  FFTW support:               yes

  FreeType support:           no

  GDAL support:               yes

  GEOS support:               no

  GLw support:                no

  JPEG support:               yes

  LAPACK support:             no

  Large File support (LFS):   no

  Motif support:              no

  MySQL support:              no

  NLS support:                no

  ODBC support:               no

  OGR support:                yes

  OpenGL support:             yes

  PNG support:                yes

  PostgreSQL support:         no

  Python support:             yes

  Readline support:           no

  SQLite support:             no

 Tcl/Tk support:             yes

  wxWidgets support:          yes

  TIFF support:               yes

  X11 support:                yes


Then: make

GRASS GIS compilation log


Started compilation: Wed Dec 28 12:22:59 CET 2011


Errors in:

No errors detected.


Finished compilation: Wed Dec 28 12:24:11 CET 2011



And su -c 'make install' that seems ok.


However when I run:  grass64 -wxpython I have the following error message:


Cleaning up temporary files ...

Starting GRASS ...

ERROR: wxGUI requires wxPython. No module named wxversion

Error in GUI startup. If necessary, please

report this error to the GRASS developers.

Switching to text mode now.

Hit RETURN to continue...


Where did I go wrong?


Many thanks in advance.


A.      Clerici

Parma University

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20111228/d8363dca/attachment.html

More information about the grass-user mailing list