[GRASS-user] erroneous creation of single-point boundary

Shane Litherland litherland-farm at bigpond.com
Mon Dec 26 07:50:02 EST 2011

Hi again,

I mentioned in an earlier post when GRASS crashed, that I eventually
fixed via tcltk instead of wxgui, and found in the process a
single-point boundary in the area I'd been digitising prior to a crash.

I've found a few more times, that a single-point boundary gets
incorrectly created, it seems to be when I am trying to do a small
boundary and maybe the snapping process is interfering with it?

I can, for example, have an existing boundary (say, one that will be a
common boundary between two areas when I'm finished).
I might activate the boundary tool, left click on one end of the
existing boundary to start another boundary, go out a short distance,
left click again to create a vertex, then left click at other end of
existing boundary and right click to finish. prior to the final right
click, there is a yellow dotted line and vertices to show my new
boundary will form a triangle beside the existing boundary. After the
right click, I cannot see anything where this triangle should be. Upon
closer inspection, I find a single-point boundary where I did the first
click to start the boundary (usually obscured by the node/vertex of the
existing boundary).

On one or two occasions, rather than it 'reverting' to a single point,
it has 'reverted' to a boundary between the first and second vertex,
i.e. an unclosed boundary, it seemed to 'lose' the third vertex that
should have closed the new boundary to the existing one.

when these glitches occurred, I tried a few times to delete the faulty
boundary and do it again, but the same error happened. I found I had to
zoom in on the map, so that my new boundary / mouse-clicks were further
apart?? this is why I suspected the snapping setting might be
'interfering', even though whilst drawing the boundary it appeared to be
snapping to the nodes I intended.

can anyone else repeat this scenario? i'm on wxgui 6.4.2RC2 ubuntu
If anyone else can validate my experience I'll follow it up in the bug


More information about the grass-user mailing list