[GRASS-user] v.dissolve doesn't create singlepart features

-C.R- hartreim at gmx.net
Tue Jan 18 07:00:01 EST 2011

Hello Grass-Users and -Experts, 

I'm trying to realize ArcGIS processes in GRASS.  In this context I tried to
dissolve the boundaries of adjacent areas of the same category (type of
column is 'character') to afterwards calculate their size. While doing this
I met the following problem. 
Because of the fact that v.dissolve uses v.reclass the dissolving procedure
creates only multipart features (according to the classes created by the
category-based reclassification). What I need are single area features of
the same category (without matched together to a few classes). This way I
would be able to address every individual dissolved area and calculate its
The spatial dissolving on its own works well and generates the expected
number of areas respectively centroids. But the simultaneously created table
only shows a few records/classes (cats with the dissolve-column as
I tried already to drop the table, delete the vector-db connection and
recategorize the dissolved map, but I didn't succeed this way. 

I hope anybody can help me. 


P.S: I'm working with GRASS 6.4.0svn, db-driver: PostgreSQL on Linux
P.P.S: Sorry for possibly receiving this message again and again, but I had
problems with subscribing.
View this message in context: http://osgeo-org.1803224.n2.nabble.com/v-dissolve-doesn-t-create-singlepart-features-tp5935306p5935306.html
Sent from the Grass - Users mailing list archive at Nabble.com.

More information about the grass-user mailing list