[GRASS-user] Running a Pyhton Script on Mac (Mapcalc)

Johannes Radinger JRadinger at gmx.at
Wed Mar 23 03:29:12 EDT 2011

Am 23.03.2011 um 05:22 schrieb Glynn Clements:

> Johannes Radinger wrote:
>> I'd like to run a python script on my GRASS6.5 on MacOS.
>> I saved a *.py script for testing with following content on my desktop:
>> All the needed files (upstream_part, shreve) are existing in the
>> location and mapset that is open. Then I tried to execute
>> File-->Launch Script and choose it. Then I just get back:
>> Launching script '/Users/Johannes Radinger/Desktop/mapcalc-test.py'...          
>> (Tue Mar 22 10:57:15 2011)                                                      
>> /Users/Johannes Radinger/Desktop/mapcalc-test.py                                
>> (Tue Mar 22 10:57:15 2011) Command finished (0 sec)
>> and nothing happend and no map was created...
>> what is wrong with my script?
> Does the script have execute permission ("chmod +x ...")?

The script has execute permission so far as I think, but anyway I ran chmod +x on the file...

> Does MacOSX have the Python interpreter at /usr/bin/python?
> It's common practice for Python scripts to use:
> 	#!/usr/bin/env python

my first script included #!/usr/bin/env python, but it failed (error message) it couldn't find python, thats why I googled  and found: http://macosx.com/forums/unix-x11/46163-how-do-i-run-python-script.html
that is why i used /usr/bin/python.

I just got the tip in forum to check for the line-endings in the file, they might cause the problem, so I will check that.

But anyway, is there any other possible reason why I fail?
Is there any Mac-User with Python-Script-Mapcalc experience?

> which only requires that "python" is somewhere in $PATH, rather than
> assuming a fixed location. The Python scripts in 7.0 use this
> mechanism.
> -- 
> Glynn Clements <glynn at gclements.plus.com>

More information about the grass-user mailing list