[GRASS-user] Problem with Python Scripts and grass.script (GRASS 6.5SVN) on Mac

Johannes Radinger JRadinger at gmx.at
Tue Mar 29 05:11:12 EDT 2011

Hello Grass users!

I am working with GRASS 6.5 SVN (r45714, last weeks source) and try to run Python Scripts. After I solved the problem with the line endings, GRASS seems to be able to read my scripts (via launch script...). At least the interactive interface pops up correctly (it seems g.parser can read all my options etc.), but after executing it nothing happens and nothing is processed. I tried it with mapcalc but also with r.thin (one input, one output, so very simple).

I don't know what is the problem or how can I check what the problem is...
...what I've tried already and which may cause the problem is that I cannot import grass.script (import grass.script) in the Terminal (pyhton) and/or IDLE... it says: module not found...

Just for your information I run GRASS on a Apple Mac Snow Leopard (10.6.6)
with Python 2.6.6.

NEU: FreePhone - kostenlos mobil telefonieren und surfen!			
Jetzt informieren: http://www.gmx.net/de/go/freephone

More information about the grass-user mailing list