[GRASS-user] mysql v.dissolve

sluedtke sluedtke at gfz-potsdam.de
Wed Nov 23 08:19:40 EST 2011

Dear friends,

there was similar thread before but I could not follow the solution and the
grass version changed in the meantime.

I run grass 6.4.1 on an ubuntu 10.04 LTS system and I am quite happy with
that. I changed to a MySQL database connection by default some weeks ago and
that makes a lot of work much easier. 

Only one issue remains: Whenever I try to use "v.dissolve" on any vector
dataset the resulting vector dataset does not hold any table- which makes
the tool quite useless.

I don´t get any error messages but just no table. I am sure that the
database connection works, since I call "v.dissolve" from a script and all
the other operation before work fluently. When loading the new (dissolved)
dataset it says:  "Database connection for vector map test_diss at PERMANENT>
is not defined in DB file. You can define new connection in 'Manage layers'

On all the other operations, the table and the connection between the vector
and table was set automatic- but maybe I miss something this time. I tried
the spearfish dataset with the default DBMS and it works. The last thread
dealing with this issue was about grass 6.3 ... and nearly all the SQL
drivers caused problems. 

Apologize any forgotten info, it is my first post ever in my life. 

Thanks in advance,


[I had a pending message for 3 days with my last try. I hope I did not
double post]

View this message in context: http://osgeo-org.1803224.n2.nabble.com/mysql-v-dissolve-tp7024313p7024313.html
Sent from the Grass - Users mailing list archive at Nabble.com.

More information about the grass-user mailing list