[GRASS-user] orthophoto georeferencing stops working when adding points

Shane Litherland litherland-farm at bigpond.com
Tue Oct 11 02:27:53 EDT 2011

Hi all,

GRASS 6.4.1 on ubuntu 10.04 64 bit, tcltk GUI (because of other wxpython
probs previously reported)

Have been trying my hand at orthophoto georeferencing.

I started with a digital image that was taken with a digital aerial
camera. Has most of the camera settings required for the orthophoto
parameters asked for in the steps. As the image is direct from the
camera I didn't have a fudicial marks etc to do one of the steps but
that didn't seem to be a problem.

Seemed to be going OK, putting in parameters etc.

Got up to option 7 (as per what shows in a terminal after i.ortho.photo
is run from the GUI menu

I have put in 4 control points using the monitor. For each one, i used
zoom-box to get up closer before positioning point, and using keyboard
to enter GCP co-ords.

I then did a fifth point. it seemed to work OK, but then when trying to
do zoom for another point, get messages:
WARNING: Unable to find <raster_i_am_georeferencing> (click mouse to
[so i click mouse, then second message]
WARNING: Unable to open raster map <ditto> (click mouse to continue)
[click mouse again, options along bottom of screen come back, so I quit]

I have tried repeatedly with fresh sessions of GRASS, to add more points
without luck. Also noted that only four GCP's are saved. each time I
start it up, I can apparently add GCP #5, and then get warnings after
that, but that #5 point isn't being saved to the control points file.

I tried a workaround: open up the GCP monitor/terminal, zoom and click a
point, then go and open up the control-points text file and manually
enter in that point co-ords and matching control co-ords. Go back to the
monitor/terminal and hit 'enter' to blank out the point I'd just clicked
on. Then tried zooming on another spot of the map, still got the errors.

Opened up a fresh monitor/terminal, and noted that the point I'd
manually added to text file was displayed correctly.

Did a zoom box, actually missed where I wanted so then used zoom-point
option to try and reposition the zoomed view, got the warning messages

Dunno if it is part of same thing, but notice when I hit 'analyse' that
the errors for east and north are up around 657900 and -6603200
respectively, using UTM 56J wgs84 (i.e. metres). target points are
around 476900 and 7096500.
It's a while since I've done some georeferencing, but these figures just
seem too wrong. or does the error get calculated at the next stage and
these are really just dummy/filler numbers?

I tried another work around - run the 'georectify' tool from GUI menu,
as far as the i.points part I think? i.e. enough to put one example
point into the points text file. Then I copied the points from 'control
points' text file for ortho-photo process, over to the points file for
the regular process, noting the spaces, elevation etc that wasn't
relevant for the points file.

I could open that up in the georectify monitor, and the error shown for
each of the points was more along the lines of 0.7 - 26 forward error
and 5 - 125 backwards error (1st order rectification). That's hugely
different from what I reported above in ortho-photo analyse.

What have I done, that it was happy to input 4 points and after that I
can't work it?

If I have to manually add points to the text file, one at a time and
restart i.ortho.photo each time, I will eventually achieve what I want.
but that's time consuming, and absolutely not what the program was
designed for, right? :-\ On the other hand, I could go back to what I've
done before with the 'basic' georectify (i.points etc) but that won't
let me add elevation data to an image like orthophoto does??


More information about the grass-user mailing list