[GRASS-user] v.digit in 6.4.2RC1 wxGUI destroyed my vectors, OK second attempt.

Shane Litherland litherland-farm at bigpond.com
Wed Oct 19 23:23:11 EDT 2011

Hi again,

last night I was playing with the wxGUI digitiser, first time I've used
it (was not available in 6.4.1?)

In figuring out how select/commit worked a little different with mouse,
and how the display showed 'live' movements, I used the move/add/remove
vertex tools, the edit line/boundary, move features, and delete

Somewhere in my experimenting, the whole thing went weird on me. Started
showing random lines from corner of window to my (moving) mouse cursor,
duplicated boundaries when I chose to move a single point, refused to
close after clicking on the 'exit digitising' button and choosing
'no-don't save'. Eventually, ended up with most of the vector layer gone
(it was composed of boundaries and centroids), topology obviously
stuffed, one boundary I hadn't gone near still showed on the map and the
last half-dozen 'moves' of another boundary showed as half-dozen
overlapping boundaries, each with one of the vertices (whichever I'd
moved in that step) in a different position.

Got a whole heap of error messages in output and also topology errors in
terminal from where I ran GRASS. Can post them if anyone interested.

Had to dig out a backup of that vector and restore it to the GRASS

Have tried, much more carefully, to repeat process this morning. Adding
vertex, moving boundary/centroid, moving vertices, seems to be OK.

So far, only thing I can find again, is when choosing 'exit' and 'no',
the changes I just did ARE saved (e.g. i'd opened digitiser, moved a
boundary, exit-nosave, but boundary shows where I'd moved it to, not
where it was previously). Doesn't seem right to me - I know the tcltk
digitiser saved things as they were done, does the wxGUI in fact do the
same thing, in which case why the yes/no option to save when quitting

Tried a couple of tools from 'additional tools' icon/menu; some like
'split line/boundary' I've used before, and can find a v.split page in
GRASS help, whereas others like merge, connect, even snap, seem to be
new options or modifications of older techniques, which didn't do what I
expected initially, and couldn't find something in GRASS help where I
expected to, e.g. v.connect, v.merge, etc...

Any pointers on where to look for info on the 'additional tools' would
be appreciated. I've got enough grasp of the main tools in digitiser
that have their own icons already.

As for repeating my destruction of a vector layer, who knows? maybe
clicking left mouse button to select, then again to where I wanted to
move/add a vertex when I shoulda used right button (that was how old
tcltk worked - left select, left new spot, right commit - old habits!)
confused it before I finally clicked right button. Or clicking on a
centroid with 'move vertex' tool (no move happened, but centroid did
momentarily disappear until i right-clicked again)... or when the 'exit
digitiser' seemed to partly return the map display to 2d view but still
left the digitising toolbar showing, and I then re-opened the vector to
digitise some more... I think I was a fair way into playing before I
started noting odd things and recording the error messages.


More information about the grass-user mailing list