[GRASS-user] Problem after Installing OS X 10.7

William Kyngesburye woklist at kyngchaos.com
Mon Sep 12 10:11:20 EDT 2011

Hmm, the GUI shouldn't be any different than it is on earlier systems.  In fact, there may be new problems because Lion got rid of the rest of Carbon (as I understand it) and wxPython in GRASS is still Carbon-based.  A cocoa-based wxpython currently doesn't work in GRASS.

On Sep 12, 2011, at 8:53 AM, Kurt Springs wrote:

> That worked great William, thanks.  I was pleasantly surprised by the the Python GUI that is used under Lion, though I may have to learn my way around it.
> Thanks again all.
> Kurt
> On Sep 12, 2011, at 9:41 AM, William Kyngesburye wrote:
>> sudo chown -R yourusername /path/to/your/grassdb
>> On Sep 12, 2011, at 7:25 AM, Kurt Springs wrote:
>>> How would one go about transferring ownership?
>>> Kurt
>>> On Sep 11, 2011, at 1:00 PM, Michael Barton wrote:
>>>> It sure looks like permissions are the problem here. The GUI needs to write things to your GIS Database and to temp files. If you are not the owner, there could be problems.
>>>> Michael
>>>> ____________________
>>>> C. Michael Barton
>>>> Director, Center for Social Dynamics & Complexity 
>>>> Professor of Anthropology, School of Human Evolution & Social Change
>>>> Arizona State University
>>>> voice: 	480-965-6262 (SHESC), 480-727-9746 (CSDC)
>>>> fax:          480-965-7671 (SHESC),  480-727-0709 (CSDC)
>>>> www: http://www.public.asu.edu/~cmbarton, http://csdc.asu.edu
>>>> On Sep 11, 2011, at 2:12 AM, <grass-user-request at lists.osgeo.org> wrote:
>>>>> Date: Sat, 10 Sep 2011 19:21:05 -0400
>>>>> From: Kurt Springs <ferret_bard at mac.com>
>>>>> Subject: [GRASS-user] Problem after Installing OS X 10.7
>>>>> To: grass-user at lists.osgeo.org
>>>>> Message-ID: <B87EF884-61E7-4BD9-A790-0C4E80844E48 at mac.com>
>>>>> Content-Type: text/plain; charset="windows-1252"
>>>>> Hi Folks,
>>>>> I finally installed OS X 10.7.1.  Because I had a corruption with Java I did a clean install.  I?ve been gradually loading things back in. I ran into trouble when I got to GRASS.  I have William Kyngebure?s 6.4.1-5.  I launched it for the first time and got the following in Terminal:

William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

"The beast is actively interested only in now, and, as it is always now and always shall be, there is an eternity of time for the accomplishment of objects."

- the wisdom of Tarzan

More information about the grass-user mailing list