[GRASS-user] Fwd: GRASS on SSHFS

Daniel Lee lee at isi-solutions.org
Mon Dec 10 04:17:41 PST 2012

I accidentally just sent this to Glynn, rather than the list ;)

---------- Forwarded message ----------
From: Daniel Lee <lee at isi-solutions.org>
Date: 2012/12/10
Subject: Re: [GRASS-user] GRASS on SSHFS
To: Glynn Clements <glynn at gclements.plus.com>

@Markus - Yes, I can use touch to create files (was also my first test)

Here's the output of ls -la:

ls -la
total 12
drwxrwxrwx 1 1002 9150  22 Dec  7 12:15 .
drwxrwxrwx 1 1002 9150  23 Dec  7 11:09 ..
drwxrwxrwx 1 1002 9150 129 Dec  7 12:14 PERMANENT

I think Glynn's right about the permissions being the problem. Even though
everybody has permissions here, the folders' owner is my SSH user, which is
different than the username on my own machine. It seems that's the source
of my troubles. Sadly, I don't see a way of getting around that except for
doing some really complicated SSH tunneling stuff or recompiling GRASS. The
easier way out is just contacting the system administrator of the server
I'm working on, which I've done - hopefully she'll have installed GRASS on
it by tomorrow, so that's one less thing to worry about.

That aside, though, is there a specific reason that GRASS requires the user
to own a mapset, rather than just have write permission?


2012/12/9 Glynn Clements <glynn at gclements.plus.com>

> Daniel Lee wrote:
> > I'm working on a server that unfortunately does not have GRASS installed
> on
> > it. In order to work on my large amounts of data there, I've mounted the
> > external file system with ssh using SSHFS. This works fine and I can read
> > and write data without problems.
> >
> > I've made a GRASS location on that server, which also worked fine, and
> > creating all of the locations and mapsets using the GRASS GUI worked
> > without a hitch. But every time I try to perform any command within a
> > mapset, I get the following error:
> >
> > ERROR: MAPSET PERMANENT - permission denied
> >
> > It doesn't matter what the command is (g.region, g.list, g.gui) or
> whether
> > the mapset is PERMANENT or another. I can create the mapsets, I just
> can't
> > work in them.
> >
> > Just as an experiment, I changed the rights for the GRASS DB on the
> server
> > to 777 recursively (there's nothing in there anyway since I can't do
> > anything on it). This doesn't make a difference, though.
> >
> > Anybody know what the problem could be?
> GRASS requires that you are the owner of the current mapset,
> regardless of its permissions.
> Ideally, you should try to persuade sshfs to maintain ownership
> correctly (i.e. a newly-created directory should be owned by the user
> who actually created it).
> Failing that, you can modify G__mapset_permisssions() in
> lib/gis/mapset_msc.c and re-compile.
> --
> Glynn Clements <glynn at gclements.plus.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20121210/1a0be51b/attachment.html>

More information about the grass-user mailing list