[GRASS-user] r.basin does not complete properly on one stream

Rich Shepard rshepard at appl-ecosys.com
Thu Oct 25 16:40:40 PDT 2012

   For a reason I've not been able to determine in a long day today r.basin
fails to properly complete when passed easting/northing coordinates of a
cell generated by r.stream.extract. The last three ratios are shown as NAN
and the area is shown as only 4km^2 when it's actually much larger. With
other sub-basins this result was corrected by moving the outlet point
further upstream from the confluence with a larger stream.

   Following the r.basin wiki that madi wrote, I re-extracted the streams
from the DEM. Ran r.watershed to generate an accumulation map, then
r.stream.extract. Both modules take the same DEM map (named dem_proj). But,
when I place the outlet point several cells above the confluence r.basin
does not properly complete. I tried moving the outlet away from the
confluence, but still no joy.

   The attached PDF shows the outlet point sitting in the middle of a cell on
the stream_network raster generated by r.stream.extract.

   I'm at a loss to understand why this one sub-basin is fighting me, and I
would like outside opinions on what might be the cause and suggestions of
what to try to isolate the cause of this problem. If more information is
desired, I'll try to provide it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: stream-map.pdf
Type: application/pdf
Size: 8758 bytes
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20121025/7f8d91ec/attachment.pdf>

More information about the grass-user mailing list