[GRASS-user] Reading file with with space separators

Hamish hamish_b at yahoo.com
Wed Apr 17 14:20:10 PDT 2013

Ralf wrote:
> However, I still get an error, although I now have 1-space
> delimited file.
> r.in.xyz fs='space',
> input=dgm10_32292_5548_2_rp_one_space.xyz out=test
> I already achieved the task with the help in R now, but from
> academic point would really be interested why is not
> working. I obtain the error message:
> ERROR: Not enough data columns. Incorrect delimiter or
> column number? Found
>        the following character(s) in row 1:
>        [293220.000 5550000.000 311.432]

try  fs=space
I think the other (with the comma) is a typo.

> I uploaded sample files here:
> http://www.sendspace.com/file/8q3vrx
> Perhaps this makes reproduction of the problem easier...

works for me:
GRASS65> r.in.xyz -s in=dgm10_32292_5548_2_rp_one_space.xyz out=dummy x=1 y=2 z=3 fs=space
Range:     min         max
x: 293080.000000 293990.000000
y: 5548130.000000 5549990.000000
z:  256.851000  426.240000

then import worked well using a 10m grid resolution.
(grid resolution confirmed by running r.univar on the method=n
map + 'r.null setnull=0')


More information about the grass-user mailing list