[GRASS-user] libgrass_gmath

Markus Neteler neteler at osgeo.org
Sun Feb 23 15:06:22 PST 2014


On Sun, Feb 23, 2014 at 11:58 PM, Dave Roberts
<dvrbts at ecology.msu.montana.edu> wrote:
> Markus,
>    Despite (or perhaps because of) downloading and installing new wxPython,
> gdal, fftw, and others I have forgotten, compiling grass7_trunk generated
> numerous errors.  libgrass_gmath.7.0.svn.so compiled successfully, but then
> whether I set --with-fftw or --without=fftw libgrass_gnath generated
> numerous errors related to missing references in fftw.  E.g. in r.gwflow
> /libgrass_gmath.7.0.svn.so: undefined reference to `fftw_execute'
> /libgrass_gmath.7.0.svn.so: undefined reference to `fftw_plan_dft_2d'
> /libgrass_gmath.7.0.svn.so: undefined reference to `fftw_destroy_plan'

Do you have both fftw and fftw-devel installed?

>   I noticed that the routines generating the errors are routines I don't
> call, so despite the errors I tried make install and it worked!
> However, I still have the problem that v.dissolve doesn't work.

This will be a cascaded dependency issue: once
libgrass_gmath.7.0.svn.so is right, also v.dissolve will start to


More information about the grass-user mailing list