[GRASS-user] Label vector map

henk witte henk.witte at groenholland.nl
Mon Aug 24 23:51:27 PDT 2015

Dear Anna,

Thanks for your suggestions, I have tried the North Carolina dataset (using the NAME attribute of the counties as label) and this indeed works fine. I have also tried my original file, and there I still have problems.

The vector (polygon) files I wanted to label have been created from two separate source files (imported from esri shape files) that I have merged. During the merge I noted a number of problems with the polygons, although it now displays OK. After this I joined the vector file with a new attribute table. I can use that to color the polygons (create thematic maps) but I cannot label the polygons even if I use the grass-generated “cat”column.

I have tried not specifying a font at all (default) and then did specify a font to see if that would help. Unfortunately not.

I have added the vector file (directory) as a zip file to this email.

Thanks for any further assistance!


From: Anna Petrášová [mailto:kratochanna at gmail.com]
Sent: 21 August 2015 17:58
To: henk witte <henk.witte at groenholland.nl>
Cc: grass-user at lists.osgeo.org
Subject: Re: [GRASS-user] Label vector map

On Fri, Aug 21, 2015 at 5:24 AM, henk witte <henk.witte at groenholland.nl<mailto:henk.witte at groenholland.nl>> wrote:
Dear grass-users,

I am trying to put labels in a polygon layer, but the rendering fails. The details are:

Problem signature:
  Problem Event Name:                        APPCRASH
  Application Name:                             d.vect.EXE
  Application Version:                 
  Application Timestamp:                     55ae1991
  Fault Module Name:                          libgrass_driver.7.0.1svn.dll
  Fault Module Version:              
  Fault Module Timestamp:                  55ae17e1
  Exception Code:                                  c0000005
  Exception Offset:                                00002aa5
  OS Version:                                          6.1.7601.
  Locale ID:                                             2057
  Additional Information 1:                  0a9e
  Additional Information 2:                  0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:                  0a9e
  Additional Information 4:  0a9e372d3b4ad19135b953a78882e789

The command I use (through the GUI) is:

d.vect --quiet map=AlleKavels at GoesShape attribute_column=Kavel_nr width=1 font=romans label_color=black

Any suggestions?

Perhaps if you could replicate the problem on North Carolina sample dataset or provide your vector file, it would help identify the problem. Does it happen with other vectors or attribute columns? Have you tried different font or not specify it at all?


Henk Witte
Groenholland Geo-energysystems
Valschermkade 26
1059CD Amsterdam

T: +31 (0)20 6159050<tel:%2B31%20%280%2920%206159050>
M: +31 (0)628176535<tel:%2B31%20%280%29628176535>
E: henk.witte at groenholland.nl<mailto:henk.witte at groenholland.nl>

grass-user mailing list
grass-user at lists.osgeo.org<mailto:grass-user at lists.osgeo.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20150825/94daf244/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: AlleKavels.zip
Type: application/x-zip-compressed
Size: 157558 bytes
Desc: AlleKavels.zip
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20150825/94daf244/attachment-0001.bin>

More information about the grass-user mailing list