[GRASS-user] DEM with bathymetric contour lines

Tomáš Brunclík brunclik at atlas.cz
Mon Jun 1 02:44:53 PDT 2015

Hi Irantzu,
I am just trying again with this dataset:
It is cosiderably smaller than yours, with 1m resolution the region is 
5676x4142 pixels, but running r.surf.contour for 15 minutes and still 0% 
done. Hope it is able to finish before I have to leave, I have common 
office PC. In any case I will let you know what was the result, you can 
try with the same data for comparison.
Looking at the data, which are of some inland water body, I see the most 
of the region area is covered by land, which is not covered by contours 
(there are contours for elevation <= 0 only). Would see how the command 
copes with that, this could possibly be source of your problems, should 
your data also contain large areas not covered by the contours. It such 
case a mask may help.

For the record, the commands I used:

#First created new location using the data as source of its projection 
settings and imported the file (from startup GUI), then:

g.region vector=ES2003_1m_mb_contour at PERMANENT

g.region res=1

g.region -p
projection: 1 (UTM)
zone:       10
datum:      wgs84
ellipsoid:  wgs84
north:      4079792.873656
south:      4074116.9543482
west:       608344.55566446
east:       612486.8266235
nsres:      0.99998578
ewres:      1.00006542
rows:       5676
cols:       4142
cells:      23509992

v.to.rast input=ES2003_1m_mb_contour at PERMANENT output=contours_rast 

r.surf.contour input=contours_rast output=dmt_rast

Dne 31.5.2015 v 20:21 Irantzu Alvarez napsal(a):
> Hi Markus and Tomas,
> Thank you very much for all your support.
> I am using Grass 7.0 in linux and I am working in a high capacity 
> computer.
> My bathymetry input file contains vector lines, and all of them have 
> an elevation value, from -2 to -116, with an interval of  1 m. The 
> file have 300 MB.
> After executing the v.to.rast command, I get a raster, and it seems 
> that is correct (pixels have the value of the elevation).
> I am trying to change te resolution in order to get the interpolation. 
> If I choose a resolution of 1 meter, the output file is exactly the 
> same as the previous one, but if I change it (for example a resolution 
> of 100 m), it works, but with a very bis pixexl size. The question is 
> that I need a high resolution DEM.
> This are the commands I have used:
> v.to.rast input=iso1 at ras type=line output=ras_ir use=attr 
> attribute_column=CONTOUR
> r.surf.contour --overwrite input=ras_ir at ras output=mdt_ras
> Regards,
> Irantzu
> 2015-05-26 10:50 GMT+02:00 Tomáš Brunclík <brunclik at atlas.cz 
> <mailto:brunclik at atlas.cz>>:
>     PS: Just another wild guess ;)
>     - Does the input vector bathymetry file contain vector lines?
>     Because when I have tried my test, what I downloaded to play with
>     contained polygons, not lines and I had to convert it to lines
>     first (something like: v.type input=bathymetry
>     output=bathymetry_lines from_type=boundary to_type=line). That
>     would also explain your difficulties..
>     Tomas
>     Dne 26.5.2015 v 10:38 Tomáš Brunclík napsal(a):
>>     Hello Irantzu,
>>     As I said, for anyone to be able to help, please post the exact
>>     commands used (all from the beginning, not just the last one
>>     which fails) and GRASS version and operating system, just like
>>     Markus did in his post. If you are using GUI tools, there is the
>>     copy button in the command dialogs, that will allow you to paste
>>     the command parameters to e-mail. Also, address the reply back to
>>     the conference - more people may have ideas.
>>     It occurs to me, that if there is no error, and the interpolation
>>     throws unchanged input raster on you, that perhaps the input
>>     raster contains zero values instead of no-data (null) values or
>>     something - then there would be nothing to interpolate... But
>>     without seeing the data or the commands used it is just wild
>>     guessing..
>>     Regards,
>>     Tomas
>>     Dne 25.5.2015 v 13:43 Irantzu Alvarez napsal(a):
>>>     Hello Tomas,
>>>     As you said, I think that the problem could be in the volume of
>>>     data. My contours are of 300 MB and if I set a region with
>>>     resolution of 1 m (the one I would like to perform) the output
>>>     raster has over 3 billion cells. Although I have a high capacity
>>>     computer, grass doen't compute the surface.  With a resolution
>>>     of 10 m my region setting are:
>>>     g.region -p
>>>     projection: 1 (UTM)
>>>     zone:       30
>>>     datum:      etrs89
>>>     ellipsoid:  grs80
>>>     north:      4818930
>>>     south:      4791480
>>>     west:       486510
>>>     east:       601280
>>>     nsres:      10
>>>     ewres:      10
>>>     rows:       2745
>>>     cols:       11477
>>>     cells:      31504365
>>>     I am trying to generalize contours, in order to reduce the
>>>     contour file, but I don't know which algorithm is better in that
>>>     case.
>>>     After that I will try to use diferrent resolutions to see if
>>>     that is the problem.
>>>     All the best,
>>>     irantzu
>>>     2015-05-25 10:12 GMT+02:00 Tomáš Brunclík <brunclik at atlas.cz
>>>     <mailto:brunclik at atlas.cz>>:
>>>         Hello,
>>>         I tried to process bathymetry lines with negative elevation
>>>         and it just worked in GRASS 7.0.1svn r65198 @Linux. Maybe
>>>         try if it works with coarser resolution or region subset to
>>>         test if the data volume is the problem, or if your version
>>>         of GRASS really has problem with negative elevation values.
>>>         Also try to look if the input raster contains expected
>>>         values, if you did not check that already.
>>>         If the problem persists, post your findings with log of the
>>>         commands you used, your GRASS version and platform.
>>>         If it seems a problem of the GRASS module, and you are using
>>>         a recent version of GRASS, it would be better to fill a bug,
>>>         instructions at
>>>         http://grass.osgeo.org/development/bug-tracking/
>>>         Regards,
>>>         Tomas Brunclik
>>>         Dne 18.5.2015 v 16:47 Irantzu Alvarez napsal(a):
>>>>         I am trying to create a DEM from a bathymetric contour
>>>>         lines. Contours are in vector format and the elevation
>>>>         value is negative (integers). To create the surface I have
>>>>         converted the contours in raster (v.to <http://v.to> rast)
>>>>         and then I have used r.surf.contour, but It doesn't work
>>>>         (there is no error but the resulting output rasteris
>>>>         exactly the same as the previous one, without any
>>>>         interpolation).
>>>>         This are my region settings:
>>>>         g.region -p -a raster=contours at iiaa nsres=1 ewres=1
>>>>         projection: 1 (UTM)
>>>>         zone:30
>>>>         datum:etrs89
>>>>         ellipsoid:grs80
>>>>         north:4818927
>>>>         south:4791484
>>>>         west:486512
>>>>         east:601275
>>>>         nsres:1
>>>>         ewres:1
>>>>         rows:27443
>>>>         cols:114763
>>>>         cells:3149441009 <tel:3149441009>
>>>>         I need a DEM of very high resolution of a wide area. I am
>>>>         using a computer with large capacities for it.
>>>>         Could someone help me please?
>>>>         _______________________________________________
>>>>         grass-user mailing list
>>>>         grass-user at lists.osgeo.org  <mailto:grass-user at lists.osgeo.org>
>>>>         http://lists.osgeo.org/mailman/listinfo/grass-user
>>>         _______________________________________________
>>>         grass-user mailing list
>>>         grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>>>         http://lists.osgeo.org/mailman/listinfo/grass-user
>>     _______________________________________________
>>     grass-user mailing list
>>     grass-user at lists.osgeo.org  <mailto:grass-user at lists.osgeo.org>
>>     http://lists.osgeo.org/mailman/listinfo/grass-user
>     _______________________________________________
>     grass-user mailing list
>     grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>     http://lists.osgeo.org/mailman/listinfo/grass-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20150601/dccdfc8a/attachment-0001.html>

More information about the grass-user mailing list