[GRASS-user] Can't load NetCDF after 7.0.4 upgrade

Ken Mankoff mankoff at gmail.com
Mon Aug 15 15:07:46 PDT 2016

Hi GRASS list,

I recently upgraded to 7.0.4 and can no longer open NetCDF files. I re-installed several components at the time of the upgrade, so this may be a gdal or other software error too. I'm not sure how to debug this, and hope someone here can help.

I try to load a variable from a NetCDF file with the following command, which worked last time I ran it in 7.0.3:

r.in.gdal input=NETCDF:foo.nc:var output=ar

I now get the following error:

ERROR 4: No such file or directory
ERROR: Unable to open datasource

However, "foo.nc" does exist in the current folder. Read/write permissions is not a problem either. This could be external to GRASS? Part of a gdal compilation issue? But "gdalinfo foo.nc" doesn't have any issues.

I'm on OS X and installed grass 7.0.4 via homebrew, which automatically installed gdal-2.0 for me as a dependency, just as it did for 7.0.3 where everything worked.

Any hints will be much appreciated.



More information about the grass-user mailing list