[GRASS-user] Problem with v.edit delete tool

Daniel Victoria daniel.victoria at gmail.com
Wed Aug 31 07:32:41 PDT 2016

Hi List,

This is probably more due to my lack of understanding of how v.edit works.
But here it goes.

I have a polygon vector layer where some of the polygons have a 'No data'
label. I'd like to delete those polygons so I ran the command, with the
following output:

v.edit map=teste at isna tool=delete where="label like '%no data%'"
Selecting features...
207 of 7200 features selected from vector map <teste at isna>
207 features deleted
Building topology for vector map <teste at isna>...
Registering primitives...
6993 primitives registered
29546 vertices registered
Building areas...
2195 areas built
264 isles built
Attaching islands...
Attaching centroids...
Number of nodes: 3086
Number of primitives: 6993
Number of points: 0
Number of lines: 0
Number of boundaries: 5017
Number of centroids: 1976
Number of areas: 2195
Number of isles: 264
v.edit complete.

After that, the offending polygons where deleted however, their boundaries
are still present. That is, when I load the vector in the map display, I
still see the boundaries in some polygons, even though the area is not
filled. Is this the intended behavior? I tried using the areadel tool but
then the whong polygon was deleted. I'm guessing the shared boundary of a
valid polygon was removed and his caused problems.

Attached is a sample of what I'm seeing after v.edit delete

[image: Inline image 1]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20160831/a066a17e/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 3543 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20160831/a066a17e/attachment.png>

More information about the grass-user mailing list