[GRASS-user] cannot start docker-grass with gui

Markus Neteler neteler at osgeo.org
Mon Jul 29 04:43:55 PDT 2019


On Mon, Jul 29, 2019 at 1:38 PM Ahmet Temiz <ahmettemiz88 at gmail.com> wrote:
> Hi,
> I tried docker version of grass ( neteler/grassgis7 )
> docker pull neteler/grassgis7
> then I ran the image :
> docker run -v $(pwd):/tmp:rw -v /tmp/.X11-unix:/tmp/.X11-unix -e uid=$(id -u) -e gid=$(id -g) -e DISPLAY=unix$DISPLAY --name grass73 -i -t neteler/grassgis7 /bin/bash
> I encountered following error when I start the gui.
> GRASS 7.7.dev (latlong_wgs84):/ > g.gui
> Launching <wxpython> GUI in the background, please wait...
> ERROR: wxGUI requires wxPython. No module named wx
> You can still use GRASS GIS modules in the command line or in Python.
> How can I start the grass with gui ?

This docker image is built without GUI support, to be used as a
head-less cloud image. For details, see


I can create a new one with GUI support if that's of interest to you.


Markus Neteler, PhD
https://www.mundialis.de - free data with free software

More information about the grass-user mailing list