[GRASS-user] garray.read() returns 0-filled array

Ken Mankoff mankoff at gmail.com
Sun Mar 15 17:14:24 PDT 2020

On 2020-03-15 at 15:11 -07, Stefan Blumentrath <Stefan.Blumentrath at nina.no> wrote...
> I have no experience with garray, but raster2numpy function in pygrass
> worked quite well for me:
> https://grass.osgeo.org/grass78/manuals/libpython/pygrass.raster.html#pygrass.raster.raster2numpy

Thank you for this suggestion. This works but raises new issues.

1) Fully external-to-GRASS interactions works better for me. This solution requires running Python from within GRASS, which adds an extra layer, which makes it harder to get to the same place interactively in Python and debug.

2) Worse, it seems I need to run the $GRASS_PYTHON version which is /usr/bin/python2.7, so I no longer have access to my scientific Python stack.

The 1st issue can be worked around. The 2nd not so much. I hope I'm mis-using the library and can do this from within my Anaconda Python.


More information about the grass-user mailing list