[GRASS-web] Installing r.green is not possible

Zambelli Pietro Pietro.Zambelli at eurac.edu
Wed Nov 20 22:05:49 PST 2019

Dear Annamarie,

sorry for the delay, finally yesterday I did have time to test the installation process on my machine and I got a similar error highlight by Markus regarding the libgreen/libhydro it seems that the makefile as it is is not any more able to handle some internal library.

To get the module installed and working you could

Download the source code with:

$ g.extension extension=r.green -d

you will get a message similar to the follow:

Fetching <r.green> from GRASS GIS Addons repository (be patient)...

To compile run:
make MODULE_TOPDIR=/usr/lib64/grass78 \
     RUN_GISRC=/tmp/grass7-pietro-65803/gisrc \
     HTMLDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/docs/html \
     RESTDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/docs/rest \
     MANBASEDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/docs/man \
     SCRIPTDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/scripts \
     STRINGDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green \

To install run:
make MODULE_TOPDIR=/usr/lib64/grass78 \
     ARCH_DISTDIR=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green \
INST_DIR=/home/pietro/.grass7/addons install

Path to the source code:

Before executing the command suggested by g.extension module you have to set the PYTHONPATH variable as follow:

export PYTHONPATH=<your r.green path>:<your r.green path>/r.green.hydro:$PYTHONPATH

So in my case is:

export PYTHONPATH=/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green:/tmp/grass7-pietro-65803/tmpixl0y9dg/r.green/r.green.hydro:$PYTHONPATH

Please let me know if the above command fix your issue, if not please provide more details regarding your OS/configuration and your errors.

Best regards


Pietro Zambelli
Eurac Research

Institute for Renewable Energy
Tel  +39 0471 055 684
Fax +39 0471 055 699
pietro.zambelli at eurac.edu<mailto:laura.scafidi at eurac.edu>

Via A.Volta 13/A

39100 Bozen/Bolzano

Legal Seat
Drususallee/Viale Druso 1
I-39100 Bozen/Bolzano

Facebook<https://facebook.com/eurac.research> l Youtube<https://www.youtube.com/EURACtv> l Twitter<https://twitter.com/eurac> l LinkedIn<https://www.linkedin.com/company/euracresearch>

According to regulation (EU) 2016/679 this transmission is intended only for the use of the addressee and may contain confidential information. If you receive this transmission in error, please notify the sender immediately by email and delete all copies of this message and any attachments.

From: Markus Neteler <neteler at osgeo.org>
Sent: 11 November 2019 18:46
To: Annemarie Pfeiffer <Annemarie.Pfeiffer at umwelt.uni-giessen.de>
Cc: GRASS-web <grass-web at lists.osgeo.org>; andre grosse-stoltenberg <Andre.Grosse-Stoltenberg at umwelt.uni-giessen.de>
Subject: Re: [GRASS-web] Installing r.green is not possible

Dear Annemarie,

Which GRASS GIS version do you use, and on which operating system?
I have tried to install it myself, on a Linux system:

GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
Fetching <r.green> from GRASS GIS Addons repository (be patient)...
Traceback (most recent call last):
  File "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
line 139, in <module>
    from libgreen.checkparameter import check_required_columns, exception2error
ModuleNotFoundError: No module named 'libgreen'
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Html.make:14:
r.green.hydro.structure.tmp.html] Error 1
DeprecationWarning: the imp module is deprecated in favour of
importlib; see the module's documentation for alternative uses
  import imp
/usr/bin/install: cannot stat
No such file or directory
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Script.make:36:
install] Error 1
Updating addons metadata file...
Updating private addons metadata file...
WARNING: No addons metadata available. Addons metadata file not updated.
Installation of <r.green> successfully finished

GRASS 7.8.2dev (nc_spm_08):~ > r.green.
r.green.biomassfor.co2          r.green.biomassfor.recommended
r.green.gshp.theoretical        r.green.hydro.financial
r.green.biomassfor.financial    r.green.biomassfor.technical
r.green.hydro.closest           r.green.hydro.optimal
r.green.biomassfor.impact       r.green.biomassfor.theoretical
r.green.hydro.delplants         r.green.hydro.planning
r.green.biomassfor.legal        r.green.gshp.technical
r.green.hydro.discharge         r.green.hydro.structure

Some issue seems to be there with "libgreen".

Do you see the same error?

Best regards,


On Wed, Nov 6, 2019 at 11:38 AM Annemarie Pfeiffer
<Annemarie.Pfeiffer at umwelt.uni-giessen.de> wrote:
> Dear Sir or Madam,
> as part of my master's thesis I would like to use the tool
> r.green.hydro with all its functions. After I've completed all the
> steps of your detailed online installation guide, Grass-Gis will
> create a field called "Energy." The functions of this field are grayed
> out and can not be executed. After entering the r.green.install -x
> command, you also receive the message that the python libraries
> numexpr and scipy are not available. After I installed these manually,
> the message did not occur anymore, but the functions in "Energy" were
> also not executable and still written in gray.
> Additionally, when you load Grass-GIS into the black console, you see
> the following message:
> Details: Can not find the executable r.green.hydro ....
> r.green.hydro ...: Unable to fetch interface description for command
> 'r.green.hydro ....' "
> Since I would benefit greatly from the use of the tool for my
> explorations, I would be very grateful if you could help me with my
> problem.
> With best regards
> Annemarie Pfeiffer
> Mit freundlichen Grüßen
> Annemarie Pfeiffer
> _______________________________________________
> grass-web mailing list
> grass-web at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/grass-web

Markus Neteler, PhD
https://www.mundialis.de - free data with free software
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-web/attachments/20191121/6a0e32d8/attachment-0001.html>

More information about the grass-web mailing list