[GRASS-web] r.futures not working

Tom Hackbarth txhackbarth at gmail.com
Wed Dec 9 02:55:37 PST 2020

Dear all,

I am trying to work my way through the r.futures workshop (
but as soon as I get to the point of using the first r.futures module -
r.futures-potential I come to a dead end.

This is the message I get:


r.futures.potential input=sampling at practice1 output=potential.csv
developed_column=urban_change_clip subregions_column=counties
Computing model...
Traceback (most recent call last):
  File "C:\Users\XXXX\AppData\Roaming\GRASS7\addons/scripts
/r.futures.potential.py", line 221, in <module>
  File "C:\Users\XXXX\AppData\Roaming\GRASS7\addons/scripts
/r.futures.potential.py", line 192, in main
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE,
  File "D:\Programme\apps\Python37\lib\subprocess.py", line
756, in __init__
    restore_signals, start_new_session)
  File "D:\Programme\apps\Python37\lib\subprocess.py", line
1155, in _execute_child
FileNotFoundError: [WinError 2] The system cannot find the file specified)


There seems to be a problem with the Python code. I also tried to work it
out on linux manjaro, but I get more or less the same error message in the

Is there anyone who can help me on this? I came not even close to
repairing the error, so I am happy about any advice one can give me.

Thank you in advance.

Best regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-web/attachments/20201209/e595d9c8/attachment.html>

More information about the grass-web mailing list