[Gvsig_italian] Etichette con stile di fondo

Antonio Falciano antonio.falciano a gmail.com
Mar 20 Dic 2011 02:32:59 PST


Il 17/12/2011 19.00, Marco ha scritto:
> Ho un problema con le etichette “definite dall'utente” associate allo “stile
> di fondo”.
> Premesso che l'etichettatura con il metodo degli “Attributi dell'etichetta
> definiti in tabella” funziona perfettamente, provo ad esporvi il problema
> che riscontro invece con il metodo delle etichette “definite dall'utente”
> associato a “stile di fondo”. Come esempio uso lo shape file di punti
> “Punti.shp” a cui è associato, nella Tabella attributi, il Campo “Val_Etich”
> (figura 1).
> Voglio etichettare i punti nella Vista con i valori del Campo “Val_Etich”,
> usando il metodo delle “Etichette definite dall'utente”
> Imposto il metodo “Etichette definite dall'utente” e scelgo l'operazione
> “etichettare tutti gli elementi nello stesso modo” (figura 2). Clicco su
> “Proprietà” della classe etichetta e da “Espressione di etichetta –
> (grammatica SLD)” seleziono e aggiungo il Campo “Val_Etich” (figura 3).
> A questo punto, se nell'opzione “Stile di fondo” seleziono “Senza stile” e
> accetto il processo di etichettatura, questo si svolge regolarmente, senza
> problema alcuno, etichettando l'insieme dei punti nella Vista secondo i
> valori del Campo “Val_Etich” (figura 4).
> Se invece nell'opzione “Stile di fondo” seleziono uno stile di fondo (ad
> esempio Text Globe), allora, sia che modifichi o meno le proprietÓ dello
> stile (figura 5 e 6), come risultato, nella Vista, ho sempre e solo lo
> “sfondo” delle etichette, la “maschera” grafica a forma di “fumetto”
> rettangolare giallo (Text Globe),  ma senza che compaia mai il valore
> numerico dell'etichetta al suo interno (figura 7).
> Ho provato ad aumentare le dimensioni, sia in pixel che in metri, del testo,
> ....ma non appare nulla, come se il “fumetto” rettangolare giallo coprisse e
> nascondesse il testo dell'etichettatura.
> Dove sbaglio?

Non sbagli... Purtroppo si tratta di un bug:
http://joinup.ec.europa.eu/software/gvsig-desktop/issue/error-labelling-when-user-defined-labels-background-style
che, a quanto pare, dovrebbe essere risolto nella 1.12.

> Sarei grato se qualcuno mi rispiegasse tutta la procedura “step by step”.

http://www.youtube.com/watch?v=YI9ceaRMtFQ
Qui gli stili di sfondo vanno bene...

buona giornata
Antonio

-- 
Antonio Falciano
http://www.linkedin.com/in/antoniofalciano



More information about the Gvsig_italian mailing list