[Liblas-commits] Problems installing libLAS-1.7.0 on Mac

James McManus jmpmcmanus at gmail.com
Sat May 12 15:44:21 EDT 2012

I'm having problems installing libLAS-1.7.0 on a Mac running Snow Leopard.
 I'm using boost_1_38_0 but have also tried boost_1_49_0.  In both cases I
get the following error message:

warning: comparing floating point with == or != is unsafe
make[2]: *** [src/CMakeFiles/las.dir/chipper.cpp.o] Error 1
make[1]: *** [src/CMakeFiles/las.dir/all] Error 2
make: *** [all] Error 2

I also get numerous other warnings before the one about.

I am able to install libLAS-1.6.1, using boost_1_38_0, but have not tried
using boost_1_49_0.  Unfortunately, when I try to import liblas into
python, I get the following error message:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
line 2, in <module>
    from core import get_version
line 155, in <module>
    las = ctypes.CDLL(lib_name)
line 353, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: dlopen(liblas_c.dylib, 6): Library not loaded:
  Referenced from: /usr/local/lib/liblas_c.dylib
  Reason: image not found

Are there solutions to either of these problems?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/liblas-commits/attachments/20120512/9dd37c85/attachment.html

More information about the Liblas-commits mailing list