[Lizmap] Lizmap installation (Debian/Apache) : web configuration section

celati Laurent laurent.celati at gmail.com
Wed Apr 26 02:23:04 PDT 2023

Hi all,
I'm taking the liberty to reply to my previous message.
Following to my previous post, For information, I limited myself to read
the page https://docs.lizmap.com/3.6/fr/install/linux.html
I did not look at the page
https://docs.lizmap.com/3.6/fr/install/configuration.html and
I confirm that the URL http://XXXX.XXXX.fr/cgi-bin/qgis_mapser… MAP=
does NOT return any error.
I therefore did not define a host for lizmap since I had already done one
for qgis server.
I created folders for the data.
I created a postgis database on a posgresql server hosted on another
server. I have created the profiles.ini.php files
I edited the file like this:

*    [jdb:jauth]    driver=pgsql    host=IP of the server    port=5432
database="XXXXXX"    user=XXXXX    password=XXXXXX    search_path=public
sslmode=disable        [jdb:lizlog]    driver=pgsql    host=IP of the
server    port=5432    database="XXXXXX"    user=XXXXXX    password=XXXXXX
  search_path=public    sslmode=disable*

I have successfully installed the lizmap web client sources.

the url http://XXX.XXX.fr/lizmap/index.php/view/app/metadata
returns me

*Not FoundThe requested URL was not found on this server.Apache/2.4.54
(Debian) Server at xxxxx-xxxx.xxxx.fr <http://xxxxx-xxxx.xxxx.fr> Port 80*

the URL http://XXXX.XXXX.fr/lizmap/


*    <?php    /**    * @lizmap package    * @subpackage lizmap    * @author
3liz    * @copyright 2011 3liz    * @link http://3liz.com
<http://3liz.com>    * @license Mozilla Public License:
http://www.mozilla.org/MPL/ <http://www.mozilla.org/MPL/>    */
require('../application.init.php');    require
checkAppOpened();    // Load the configuration
jApp::loadConfig('index/config.ini.php');    // new coordinator, which we
indicate to jApp    jApp::setCoord(new jCoordinator());    // New request
object, which we pass to the coordinator, to process the routing.
jApp::coord()->process(new jClassicRequest());*

Weird... it returns the PHP code and it must be missing the end of the code
(it starts with <?php but it should end with ?>)
maybe there is a config to do in Apache to tell it to run the PHP code
instead of returning it in text format...?
In the lizmapCOnfig.ini.php file, I only replaced the default IP
with the name of our server at the line wmsServerURL=""

When I ran php configurator.php I got NO error message.
When I ran php installer.php:

*    Installation is starting    All modules dependencies are ok
Installation starts    Module jelix installed    [error] An error occured
during the installation of the module jcommunity: error during the
connection XXXXIP of the server host postgresql        Installation is

I have successfully installed the demo. But these URLs return me a Not Found
The requested URL was not found on this server.
Apache/2.4.54 (Debian) Server at XXXXXX.XXXXXX.fr Port 80:



Thanks again for your really usefull help.

Le mar. 25 avr. 2023 à 11:57, celati Laurent <laurent.celati at gmail.com> a
écrit :

> Good morning,
> Thanks very much for your reply.
> As you noticed, by reading/applying the lizmap doc too quickly, I had
> installed Nginx whereas I already had apache installed. To avoid any risk
> of conflict, I therefore uninstalled Nginx. Although that was not the
> source of my problem.
> I deleted the lizmap.conf file that I generated yesterday under
> /etc/apache2/sites-enabled. Now I can restart apache without any problem. I
> no longer have the error message. This lizmap.conf file was indeed the
> source of the problem.
> I confirm that Apache is running on my Debian virtual server. As well as
> Qgis server. FYI, lib apache2-mod-fcgi is installed. Example URL used for
> my qgis server tests:
> http://XXXX.XXXX.fr/cgi-bin/qgis_mapser … MAP=......
> I had  already created a host for qgis server. The virtual machine is NOT
> local. There is a domain name XXXX.XXXX.fr If I understand correctly, it
> is useless for me to create a host for lizmap ? And I can consider the web
> config section finalized? FYI, under apache2/sites-enabled, I have a
> XXXX.XXXX.fr.conf file and 1 default-ssl.conf file and 1
> default-ssl.conf-out file.
> My spatial data are stored in a Postgis database hosted on another
> server/virtual machine. If I understand correctly, lizmap also uses a
> postgis db to store its own data. So In addition to the PostgreSQL server
> which currently hosts my postgis data, will I have to create a database on
> this same postgresql server dedicated to storing data used by Lizmap?
> In addition to this part config / support (for BDDs stored on another
> server / MV), I have to have create the directories for the data, then
> install the sources of lizmap web client? Then I could in theory configure
> lizmap / launch the installer and make some tests? Well, I'll try to move
> forward... Thanks.
> Le lun. 24 avr. 2023 à 18:08, Arnaud Vandecasteele <arnaud.sig at gmail.com>
> a écrit :
>> Hi,
>> Did you install the mod_proxy_fcgi package (sudo apt-get install
>> libapache2-mod-fcgid) ?
>> Also, might not be related to your problem but you have installed
>> nginx-full, nginx nginx-common.
>> Nginx is another web server. You have to choose between Apache or Nginx.
>> As they use the same port (80), you might have somes issues regarding
>> which one has been started first.
>> Arnaud
>> On Mon, Apr 24, 2023 at 7:41 PM celati Laurent <laurent.celati at gmail.com>
>> wrote:
>>> Good afternoon,
>>> On a Debian 11 virtual server, apache and qgis server are installed and
>>> working.
>>> I also installed the "qgis-lizmap-server-plugin" plugin and the "qgis
>>> plugin manager". I 'm trying now to install lizmap web client thanks to the
>>> official doc. https://docs.lizmap.com/3.6/fr/install/linux.html
>>> I have a question regarding the Web Configuration section.
>>> I installed the necessary packages: curl, openssl, libssl1.1,
>>> nginx-full, nginx nginx-common, php7.4-fpm php7.4-cli php7.4-bz2
>>> php7.4-curl php7.4-gd php7.4-intl php7.4-json php7.4-mbstring php7.4-pgsql
>>> php7.4-sqlite3 php7.4-xml php7.4-ldap php7.4-redis
>>> As requested by the doc, I created a lizmap.conf file under
>>> /etc/apache2/sites-available/ I replaced in this file the value localhost
>>> by the name of the server XXX.XXXX.fr
>>> This is the only modification made in this file.
>>> It is written in the doc:
>>> *"You should declare the lizmap.local domain name somewhere (in your
>>> /etc/hosts, or into your DNS..), or replace it by your own domain name."*
>>> I did not declare a lizmap.local domain under /etc/hosts. Is it
>>> mandatory? Or is it optional? Because i have already done a similar action
>>> for qgis server installation.
>>> Can someone explain this step? Are there any examples showing how to do
>>> this?
>>> I tried anyway to activate the virtual host
>>> *"ln -s /etc/apache2/sites-available/lizmap.conf
>>> /etc/apache2/sites-enabled/lizmap.conf"*
>>> But when I try to restart apache, I can't. With these error messages:
>>> root at XXXXXXXXXXXX:/etc/apache2/sites-enabled# systemctl status apache2
>>> ● apache2.service - The Apache HTTP Server
>>>      Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
>>>      Active: failed (Result: exit-code) since Mon 2023-04-24 15:21:31 CEST; 1min 32s ago
>>>        Docs: https://httpd.apache.org/docs/2.4/
>>>     Process: 657246 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
>>>         CPU: 30ms
>>> avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: Starting The Apache HTTP Server...
>>> avril 24 15:21:31 XXXXXXXXXXXX apachectl[657249]: apache2: Syntax error on line 240 of /etc/apache2/apache2.conf: Syntax error on line 24 of /etc/apache2/sites-enabled/lizmap.conf: Could not open configuration file /etc/apache2/fastc>
>>> avril 24 15:21:31 XXXXXXXXXXXX apachectl[657246]: Action 'start' failed.
>>> avril 24 15:21:31 XXXXXXXXXXXX apachectl[657246]: The Apache error log may have more information.
>>> avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
>>> avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: apache2.service: Failed with result 'exit-code'.
>>> avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: Failed to start The Apache HTTP Server.
>>>  ESCOC
>>> yntax error on line 24 of /etc/apache2/sites-enabled/lizmap.conf: Could not open configuration file /etc/apache2/fastcgi_params;: No such file or directory
>>> The error message seems to refer to line 24 of the lizmap.conf file.
>>> This line is:
>>> include fastcgi_params;
>>> In advance, thanks a lot for your help.
>>> _______________________________________________
>>> Lizmap mailing list
>>> Lizmap at lists.osgeo.org
>>> https://lists.osgeo.org/mailman/listinfo/lizmap
>> --
>> --------------------------------------------------------------------
>> Arnaud Vandecasteele
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/lizmap/attachments/20230426/7ea8d6a3/attachment.htm>

More information about the Lizmap mailing list