[Mapbender-dev] Prefix for Mapbender functions/classes

Christoph Baudson (WhereGroup) christoph.baudson at wheregroup.com
Thu Nov 8 11:01:17 EST 2007

Up to now, we used "mb" a lot, but now it collides with PHP's multibyte 
functions. There has been some confusion about this, so we might want to 
agree on another prefix.

Later, when we go on with the re-design, we could have a JS object in 
the global namespace with that name as well, that itself contains all 
other classes or functions, so we do not pollute the global namespace.

Maybe "mapbender" is too long; "mb" is confused with multibyte; "mpb" or 
"mpbr" could be confused with MapBuilder.

This may not be on top of our to do list.

Die Lösungskonferenz der WhereGroup
am 29. November 2007 in Bonn

W h e r e G r o u p GmbH & Co. KG

Siemensstraße 8
53121 Bonn

Christoph Baudson

Fon: +49 (0)228 / 90 90 38 - 17
Fax: +49 (0)228 / 90 90 38 - 11
olaf.knopp at wheregroup.com
Amtsgericht Bonn, HRA 6788

WhereGroup Verwaltungs GmbH
vertreten durch:
Arnulf Christl, Olaf Knopp, Peter Stamm

More information about the Mapbender_dev mailing list