[mapguide-internals] My MSI Install Issues

Jackie Ng jumpinjackie at gmail.com
Tue Mar 17 16:25:43 EDT 2009

The problem with the bootstrapper (using the GenerateBootstrapper msbuild
task) is that you don't get one physical file. 

If you try to integrate that into a self-extracting module (like I tried
with 7-zip), a stupid (bug/design decision) in the VS 2008 bootstrapper
means that setup.exe will exit once the msi is launched. At the same time
the sfx module will assume it is done and starts deleting everything
underneath. Net result: You get a message about a corrupted msi.

If I used the VS 2005 bootstrapper, this actually works, but it it just too
hackish to call that a solution (plus you'll probably need Visual Studio
2005 installed to access its bootstrapper module)

Making a bootstrapper is easy. Putting everything into a single file isn't.

- Jackie

Jason Birch wrote:
> I've created a patch that I think fixes these rollback problems and
> attached to the following ticket:
> http://trac.osgeo.org/mapguide/ticket/911
> I've tried this on a Windows 2003 install, with IIS, PHP, and it appears
> to work.  You will need to install the VS2008 SP1 redist first though;
> not sure why the MSM bundling is not working for me; I think we're going
> to have to figure out some way of creating a bootstrapper, this is
> silly.
> http://tinyurl.com/4dwx3d
> If anyone wants a copy of the installer, send me an email directly.  I
> don't have a lot of bandwidth, and this thing is up over 100Mb now, but
> I'm willing to share a bit :)
> Jason
> -----Original Message-----
> From: Crispin_at_1Spatial
> Sent: March-16-09 11:00 AM
> To: mapguide-internals at lists.osgeo.org
> Subject: [mapguide-internals] My MSI Install Issues
> Hi,
> Got another MSI today but can't get it to install... it rollsback at the
> end
> of the web services file-copy so I have two issues (logs are from the
> install).
>  1) Server Only Install
> Looks like I am missing the service registration element?
> Info 1721. There is a problem with this Windows Installer package. A
> program
> required for this install to complete could not be run. Contact your
> support
> personnel or package vendor. Action: MgServerInstallCA, location:
> C:\Program
> Files\OSGeo\MapGuide Server\bin\mgserver.exe, command: install "MapGuide
> Server 2.1" 
>  2) Web Server Extensions (.net Only)
> Gets so close... it's a bit harsh doing a complete rollback if the
> config
> fails - looks like there are things that try to run and fail even if I
> select to do a manual configuration.
> Action start 10:28:03: InstallFinalize.
> Action ended 10:28:19: InstallFinalize. Return value 3.
> Action ended 10:28:21: INSTALL. Return value 3.
> Action ended 10:28:21: ExecuteAction. Return value 3.
> Action start 10:28:21: FatalError.
> Action ended 10:28:32: FatalError. Return value 2.
> Action ended 10:28:32: INSTALL. Return value 3.
> === Logging stopped: 3/16/2009  10:28:32 ===
> MSI (c) (E4:B4) [10:28:32:168]: Product: MapGuide Open Source 2.1 --
> Configuration failed.
> _______________________________________________
> mapguide-internals mailing list
> mapguide-internals at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/mapguide-internals

View this message in context: http://n2.nabble.com/Installer%3A--Yeah-baby%21-tp2464815p2493617.html
Sent from the MapGuide Internals mailing list archive at Nabble.com.

More information about the mapguide-internals mailing list