MapGuide working on FC5!

Marcus Spurkel mspurkel at
Sat Jul 22 16:39:59 EDT 2006

It took a while, but I finally got MapGuide to compile and run without 
segfault errors on Fedora Core 5.  I really wanted to see if I could get 
it working with the latest gcc (4.1) and Apache (2.2)  For those about 
to try, I salute you (<g> -- sorry).  Seriously, for the benefit of 
everyone, here are some problems that I ran into as well as the solution:

1. Don't try downloading FDO 3.2 -- I'm told it's not compatible with 
MapGuide at the moment.  Use 3.0
2. gcc 4.1 is a lot less forgiving than earlier versions.  It took many 
iterations of running "make", waiting for it to abort and then fixing 
the error before it ran all the way through.

BTW, Traian Stanev told me the "extra qualification" errors have been 
fixed but I see no evidence of that in the svn trunk or branches that I 
checked.  Have they not been published yet?

3. THIS IS KEY: apparently all those stop&go make iterations interfered 
with the overall compilation or linking process because the resulting 
mapagent binary generates a segmentation fault error as soon as you try 
to run it.  The solution?  "make clean"  and then "make" again from 
scratch.  Once it had a chance to run smoothly from start to finish, 
everything started working.

4. Because I already have Apache and PHP installed, I decided to not run 
the mapguideinstaller tar.  Instead, I looked at the script 
and tried to install just what was missing; mainly FastCGI.  As it 
stands, FastCGI DOES NOT COMPILE FOR APACHE 2.2!  The project apparently 
hasn't been updated in a while.  For anyone who wants to compile for 
Apache 2.2, go here and follow the instructions:

That's about it so far.  Like I said, it took a while -- a situation not 
helped by the fact that my test server is old and underpowered (450MHz 
P3 with 512MB RAM) so a complete "make" took about 6 hours -- but it 
does work.

Good luck everybody,

More information about the Mapguide-users mailing list