[mapguide-users] RE: MapGuide Enterprise mysteriously dies

Andy Morsell amorsell at spatialgis.com
Thu Jul 27 12:23:38 EDT 2006

So, once the IP address changes and there is failure once, is a reinstall
necessary?  Once I got back to the office, I'm fairly sure I had the same
dynamic IP I had before I left - should it have worked?  On development
machines that use dynamic IP addresses, how can we be sure that this does
not happen?



From: Trevor Wekel [mailto:trevor.wekel at autodesk.com] 
Sent: Thursday, July 27, 2006 9:17 AM
To: Andy Morsell; users at mapguide.osgeo.org
Subject: [mapguide-users] RE: MapGuide Enterprise mysteriously dies

Hi Andy,
The MapGuide Server gives out it's IP address to the Web Extensions and
MapAgent when a Service is requested.  The Server interrogates the IP
address for the machine when the mgserver process is started.  If the IP
address of the machine changes while the mgserver process is running then
you will see the behaviour you have mentioned below.  The IP address is only
given out to Service level operations.  The MapGuide Admin does not use the
same functionality.
Hope this helps,



From: Andy Morsell [mailto:amorsell at spatialgis.com] 
Sent: Wednesday, July 26, 2006 9:07 PM
To: users at mapguide.osgeo.org
Subject: MapGuide Enterprise mysteriously dies

I installed MapGuide Enterprise with the .NET web extensions about two weeks
ago on my development machine and got everything re-configured, including
WMS with the newly required Bounds parameter.  Well, after being on vacation
and trying to do some stuff with it today, it was mysteriously broken.
Everything I did that would access the web extensions would fail with:

Cannot establish connection. Exception occurred in method
MgServerConnection.Open at line 94 in file

Everything worked OK in MapGuide Admin (PHP based), when running all of the
mapagent tests, and when making WMS calls.  Studio would enumerate and
display all resource information.  But everything related to rendering a map
or a web layout would fail.  I tried to run a repair on the web extensions
and that did not help.  I had to uninstall and reinstall the web extensions
in order for the problem to disappear.  

We've seen this before with MapGuide Open, and it appears to still be a
problem.  I did not install, uninstall, or re-configure anything on this
machine during this time period.  The only thing I did was disconnect it
from it's home network and connect to the internet through a hotel internet
connection to check email.  Very strange, indeed.

Andy Morsell, P.E. 
Spatial Integrators, Inc. 
 <http://www.SpatialGIS.com> http://www.SpatialGIS.com 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapguide-users/attachments/20060727/060860b3/attachment.html

More information about the Mapguide-users mailing list