[mapguide-users] WFS and MapGuide Open?

Andy Morsell amorsell at spatialgis.com
Thu Jan 18 12:24:43 EST 2007

Thanks for the response Chris.  I tried that and no dice.  I still get the
same error message.  I've tried other WFS calls including a filter parameter
with a bounding box, but if it fails even on the most generic feature
request in the most common coordinate system, I'm not optimistic that those
will work.
Incidentally, the version that I really need to get this working on is
MapGuide Enterprise with the service packs applied.  But, I have also tried
it on MGOS 1.2.0 RC1 and MGOS 1.0.1.  It is the 1.0.1 version that I'm
actually having partial success with.



From: Chris Claydon [mailto:chris.claydon at autodesk.com] 
Sent: Thursday, January 18, 2007 8:27 AM
To: Andy Morsell; mapguide-users at lists.osgeo.org
Subject: RE: [mapguide-users] WFS and MapGuide Open?

Hi Andy,


Try adding the parameter: SRSNAME=EPSG:4326


It still fails on my current setup, but it gets me past the coordinate
system problem.





From: mapguide-users-bounces at lists.osgeo.org
[mailto:mapguide-users-bounces at lists.osgeo.org] On Behalf Of Andy Morsell
Sent: January 18, 2007 12:14 AM
To: mapguide-users at lists.osgeo.org
Subject: [mapguide-users] WFS and MapGuide Open?


I'm having some difficulty getting features via WFS from MapGuide Open
Source and MapGuide Enterprise.  This is with the standard Sheboygan sample
dataset that already has data exposed via WFS.  I also tried this on
data.mapguide.com, but apparently the WFS provider is not installed there.

 I'm having the most success here: 


But, if I actually try to GetFeatures, it results in an error: 

The coordinate system conversion failed. Unsupported coordinate system code.

The coordinate system conversion failed. Unsupported coordinate system code.
Exception occurred in method
MgCoordinateSystem.ConvertCoordinateSystemCodeToWkt at line 950 in file

I also have an MGE install and a 1.1.0 RC1 install on Linux that both report
the following error no matter what type of WFS request I use:

Invalid argument(s): [1] = " " The string cannot be empty. 
Invalid argument(s): [1] = " " The string cannot be empty. Exception
occurred in method MgFeatureSchema.SetName at line 48 in file

Does anybody have any examples of succesfully using the Sheboygan sample
dataset to retrieve features via WMS? 

Thank you. 


Andy Morsell, P.E. 
Spatial Integrators, Inc. 
 <http://www.SpatialGIS.com> http://www.SpatialGIS.com 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapguide-users/attachments/20070118/d17c69ed/attachment.html

More information about the mapguide-users mailing list