[mapguide-users] Mapguide and Maestro

Kenneth Skovhede, GEOGRAF A/S ks at geograf.dk
Tue Mar 31 02:29:02 EDT 2009

See responses inline.

Regards. Kenneth Skovhede, GEOGRAF A/S

Paulo Veríssimo skrev:
> Hi
> Here is my short experience with Mapguide Open Souce and Maestro. I 
> found some problems and some solutions. Perhaps you found the same 
> problems and perhaps some of my solutions may be helpful to you and I 
> hope some of your's may help me. I think Its all about coordinate 
> systems.
> Software versions:
> Autodesk Map 3D 2006
> Oracle 11g
> Mapguide Open Source 2.0.2
> Maestro
> SL-King FDO Oracle Provider 0.8.7
> Problem 1:
> When creating a layer in Maestro pointing to Oracle I can preview the 
> geometry but when I insert that layer in a map, I can't see anything. 
> I already tried several coodinate systems but no one works. The Oracle 
> SRID is 82176.
> Adding layers from sdf files with coordinate system XY, thay work just 
> fine <CoordinateSystem>LOCAL_CS["Non-Earth (Meter)",LOCAL_DATUM["Local 
> Datum",0],UNIT["Meter", 
> 1],AXIS["X",EAST],AXIS["Y",NORTH]]</CoordinateSystem>.
> Solution 1:
> In Maestro I edited the map xml and deleted the coordinate system, 
> leaving only the xml tags like this: 
> <CoordinateSystem></CoordinateSystem>
I have no idea why this happens. Please note that MGOS and Map3D uses 
different coordinate system libraries. This will change for MGOS 2.1.
Otherwise, try starting a new thread with "SL-King Oracle 
CoordinateSystem" in the title to get the attention of the right people.
> Problem 2:
> Can't select any feature from Oracle connections on the map. I can 
> only select features from sdf files. May be it has something to do 
> with previous problem.
> Solution 2:
> not found yet.
Make sure that the data tables in Oracle have unique primary keys 
assigned. When previewing, there should be a little star next to the 
primary key column name.
You can only select features that are marked as selectable in the map, 
and have a primary key assigned.
> Problem 3:
> Creating a raster layer in Maestro, it doen't recognize the boundaries 
> of the files. I tried tiff/tfw, jpg/jgw, and ecw/tab files but always 
> got the extents -10000000,10000000.
> Solution 3:
> With gdalinfo I produced a list of the correct coordinates and then I 
> created a config file and uploaded it in Maestro. This works very well 
> but I got problem 4
The Gdal provider does not always tell you there was an error, but 
return those extents instead. There may be files missing, or an access 
problem to the folder.
Also, if the folder contains  non-raster files, this might happen.
> Problem 4:
> Can't apply solution 3 for a second layer because I get a error 
> message from Maestro saying that the resource config already exists in 
> the server.
> Solution 4:
> not found yet.
Yes, you need to delete the previous file before uploading. That is a 
bug in Maestro, feel free to report it:

An alternative is to upload the file with a different name, and change 
the <ConfigurationDocument /> tag in the FeatureSource Xml to use the 
new file.


More information about the mapguide-users mailing list