[mapguide-users] Join Problem

_Jon_ jrizzo at Langan.com
Thu Apr 22 16:17:14 EDT 2010

My migration saga continues.  I just migrated my site from 1.1 to 2.1.  I was
able to migrate the data by exporting a package from 1.1 and loading it in
2.1.  While everything appears to have come over, some things are just not
right.  I noticed that a join which was previously working properly (as a
left outer join) is now operating as an inner join.  I opened up the feature
source where the join was defined but the join appeared to be defined
correctly.  Even though I did not make any changes, I tried saving the
feature source but Studio wouldn't let me.  It gave the error: "Length
cannot be less than zero.  Parameter name: length".  I changed a few
settings and then changed them back, wondering what would happen.  It kept
giving that error when I saved and eventually Studio crashed, throwing the
same error as an unhandled exception.  When I went back in, I re-created the
feature source & join.  It let me save the new feature source anywhere
except in it's original (correct) location.  It kept giving me that error. 
So, I tried renaming the old f.s. and moving the new one into its place. 
Now, Studio crashes whenever I try to move this f.s. into place.  I tried
deleting all layers that reference this f.s. but it did not fix the problem. 
I'm not quite sure what i can do next.  Help? (!)


View this message in context: http://osgeo-org.1803224.n2.nabble.com/Join-Problem-tp4946935p4946935.html
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list