[mapguide-users] CoordinateSystem (?) Problems with Data from WMS (EPSG: 31468 and 2398)

Sicky Christian.Rueh at rostock.zgdv.de
Tue Jan 26 11:10:31 EST 2010

Hi there!

First some basic info: I'm using MGOS 2.1 on a Windows XP SP3 Machine and

Here's what I want to do:
I want to combine multiple geodata from various WMS in one MG-Map. I was
doind fine so far and was able to add Layers using this tutorial:
In the Configuration Document I allways used 2398 in this line:
Now I had some layers, which in preview worked well. When I wanted to make a
map to combine those layers and I user 2398 as CRS nothing showed up on the
map. I then used 31468 as CRS for the map and everything worked fine. Since
these data is internal and confidential I can't give the url for the WMSs
used, sorry (I could but they would be useless).

Anyway, I now tried to incoperate more data and thus more WMS, which you can
see here:
And with these Services came the problems:
1. I used the 2398 CRS in the Config Document and 31468 in the map and it
works fine, no problems here.
2. I tried so many CRSs with this one and here are my results:
I used 2398, 31468, 25833 (*) and 25832 (*) in the Config Document and all
these in the map as CRS. the result is:
- in the layer-preview of maestro I'm able to see the layers alone when I
use 31468 in the Config Document
- no matter what CRS and initial map extent I specify in the map I just
can't see any layer on the map, all I see is a red logo in the upper left
corner ((c) LAiV-MV), the rest is white. That's also the case when I try to
look at a layer with the maestro-preview and I use a scale for which the
layer isn't made. So I think I at least made some things right, but might
miss some fundamental understanding of CRS, extents etc.
3. No matter what CRS I use in the config document or the map I always end
up with just 4326 working. This works no matter what CRS is specified in the
map, but leads to these problems:
It looks like this with MGOS: http://sicky.i-networx.de/temp/lung_mgos.PNG
which obvousily isn't correct when you look at this:
The second pic is from uDig with which everything works fine. The first,
second and third wms are all working fine together no matter what CRS I use
in uDig and everything looks perfect.

I put together the resource and config document for one example-layer from
each WMS here:

I would be very glad if somebody could try it out and hopefully could tell
me what I'm doing wring. I hope, that I gave sufficient information and that
my problems are clear and reproduceable.

Thanks in advance,

* = I read here
that 35833 and 35832 which are specified in the Capabilities Document are
25833 and 25832 in the end.
View this message in context: http://n2.nabble.com/CoordinateSystem-Problems-with-Data-from-WMS-EPSG-31468-and-2398-tp4461491p4461491.html
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list