[MapProxy] FW: Setting up a Production Server w/ FastCGI and Apache

Lars Schrader schrader at geoinformationsdienst.de
Wed Jun 16 04:50:24 EDT 2010

Hello Marc,

thank you for the work you have done.
I also have tried to install the connection between apache2 and mapproxy 
but without success.

The fcgi-socket of mapproxy is running and I can access it with the 
lighttpd web server without problem.

After this I have tried your configuration:

<IfModule mod_fastcgi.c>
   FastCGIExternalServer /var/www/mapproxy -socket 
   Alias /proxy /var/www/mapproxy

---> /var/www/mapproxy is only an empty (real) directory?

When I restart the apache 2 I get the following entry inside 

[Wed Jun 16 10:22:06 2010] [notice] FastCGI: process manager initialized 
(pid 3686)
[Wed Jun 16 10:22:06 2010] [notice] mod_python: Creating 8 session 
mutexes based on 6 max processes and 25 max threads.
[Wed Jun 16 10:22:06 2010] [notice] mod_python: using mutex_directory /tmp
[Wed Jun 16 10:22:06 2010] [notice] Apache/2.2.14 (Ubuntu) 
mod_fastcgi/2.4.6 mod_python/3.3.1 Python/2.6.5 configured -- resuming 
normal operations

That sounds ok for me.

When I try to access

I get the following entry into /var/log/apache2/access.log - - [16/Jun/2010:10:36:02 +0200] "GET 
HTTP/1.1" 404 320 "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv: 
Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3"

Do you have an idea what I have done wrong? Thank you for your help.

Greetings, Lars

More information about the MapProxy mailing list