[MapProxy] install mapproxy on a production system (lighttpd)

Lars Schrader schrader at geoinformationsdienst.de
Tue May 25 10:01:23 EDT 2010


the last days I have tried to install mapproxy as a production system 
(lighttpd) without luck.

First I have tried to use the development environment with the Paste 
Server -> paster serve etc/develop.ini --reload
Very good work!!!!

After this I have started to install the production system.

1. Edit /etc/lighttpd/lighttpd.conf

$HTTP["host"] == "mapserver" {
   fastcgi.server = (
     "/proxy" => ((
       "check-local" => "disable",
       "socket"      => 

After starting the lighttpd web server and accessing
-> http://mapserver/proxy/service? (web browser)
I got the following error into /var/log/lighttpd/error.log

2010-05-25 13:43:44: (log.c.166) server started
2010-05-25 13:43:58: (mod_fastcgi.c.1734) connect failed: No such file 
or directory on unix:/home/meier/MapProxy-0.8.2/mymapproxy/var/fcgi-socket
2010-05-25 13:43:58: (mod_fastcgi.c.3037) backend died; we'll disable it 
for 1 seconds and send the request to another backend instead: 
reconnects: 0 load: 1
2010-05-25 15:32:52: (mod_fastcgi.c.2864) fcgi-server re-enabled: 

2. Install mapproxy application and the fci-socket

cd home/meier/MapProxy-0.8.2/mymapproxy

paster setup-app etc/config.ini

After this command I got the following error:

(mapproxy)meier at mapserver:~/MapProxy-0.8.2/mymapproxy$ paster setup-app 

Traceback (most recent call last):
   File "/home/meier/MapProxy-0.8.2/mapproxy/bin/paster", line 9, in 
     load_entry_point('PasteScript==1.7.3', 'console_scripts', 'paster')()
line 84, in run
     invoke(command, command_name, options, args[1:])
line 123, in invoke
     exit_code = runner.run(args)
line 68, in run
     return super(AbstractInstallCommand, self).run(new_args)
line 218, in run
     result = self.command()
line 454, in command
     installer = self.get_installer(dist, ep_group, ep_name)
line 234, in get_installer
     'paste.app_install', ep_name)
line 2228, in load_entry_point
     raise ImportError("Entry point %r not found" % ((group,name),))
ImportError: Entry point ('paste.app_install', 'app') not found

Is this the right way to install mapproxy as a produktion system? I hope 
somebody can help me to fix this problem.

Regards, Lars

More information about the MapProxy mailing list